In current cvs, iso files no longer open as vfs

Showing 1-15 of 15 messages
In current cvs, iso files no longer open as vfs Richard/g 4/19/07 7:37 AM
I know this used to work. Press enter on an ISO file to
copy out vmlinux, etc.  But for a while now, initially
after a build it won't work. then after a while, days, it
works as expected.

Is there a reason?  Something I'm doing wrong?
The phase of the moon?

regards,
Richard.

Re: [Krusader-devel] In current cvs, iso files no longer open as vfs Frank Schoolmeesters 4/20/07 11:24 AM

Does krusader report something on the konsole?
if you start krusader from a console terminal.

$ krusader <enter>

I haven't used the iso kioslave in a long time, so can't tell nothing
more about is.

bye,

Frank

Re: [Krusader-devel] Re: In current cvs, iso files no longer open as vfs Richard/g 4/20/07 3:56 PM
On Friday 20 April 2007 14:24, Frank Schoolmeesters
wrote:

>
> On 4/19/07, Richard/g <richa...@gmail.com> wrote:
> >
> > I know this used to work. Press enter on an ISO file
to
> > copy out vmlinux, etc.  But for a while now,
initially
> > after a build it won't work. then after a while,
days, it
> > works as expected.
> >
> > Is there a reason?  Something I'm doing wrong?
> > The phase of the moon?
> >
> > regards,
> > Richard.
> >
>
> Does krusader report something on the konsole?
> if you start krusader from a console terminal.
>
> $ krusader <enter>

No. No message. Still doesn't work.
It was broken and fixed some time back.
Maybe one of the changes broke it again.

Richard.ç

> I haven't used the iso kioslave in a long time, so
can't tell nothing
> more about is.
>
> bye,
>
> Frank
>
> >
>

Re: [Krusader-devel] Re: In current cvs, iso files no longer open as vfs Karai Csaba 4/23/07 6:18 AM
Works for me.

What to do:

1. Check whether the dependencies are correct:

    Konfigurator -> Dependencies

    iso protocol: application/x-iso

    If it is missing, then add it.

2. determine the mime type of your iso images.
    Krusader expects application/x-iso.

    If it is not the mime type that your distribution
    attaches to *.iso, then please e-mail us the
    correct mime type and we'll add it to the code.

    Try the correct mime with the dependencies:

    iso protocol: application/my-distro-related-iso

3. The first 2 point should solve the bug, if not, then
    try to enter the

    iso:/path/myiso.iso/        URL.

    Tell us whether the iso protocol works without Krusader
    or not.


Thanks,

Csaba


Re: [Krusader-devel] Re: In current cvs, iso files no longer open as vfs Richard/g 4/23/07 10:33 AM
On Lunes 23 Abril 2007, Karai Csaba wrote:
>
> Works for me.

And for some reason, it now works for me.
But only in some dirs: Yes in /cds
but not
in /home/richard/install/distros/debian/etch-40r0/*.iso

Must be a permissions problem?  But they are all set as
before (but maybe that's the problem. :)


 
> What to do:
>
> 1. Check whether the dependencies are correct:
>
>     Konfigurator -> Dependencies

In Dependencies, I see cpio pointing to /bin/cpio

>     iso protocol: application/x-iso

not this. This is in Protocols,
but it is not activated in Mime types.  
And since it's working, I hesitate to maybe create a
conflict.

 
>     If it is missing, then add it.
>    
> 2. determine the mime type of your iso images.
>     Krusader expects application/x-iso.
>
>     If it is not the mime type that your distribution
>     attaches to *.iso, then please e-mail us the
>     correct mime type and we'll add it to the code.

>     Try the correct mime with the dependencies:
>
>     iso protocol: application/my-distro-related-iso

I'll turn this on and see if it works everywhere:
Well, now it opens in K3b, but not in Krusader in /home*.

And the other that used to open in Krusader now opens in
K3b. So I removed it from the mime protocols, again.

> 3. The first 2 point should solve the bug, if not, then
>     try to enter the
>
>     iso:/path/myiso.iso/        URL.

This was inconclusive. Nothing worked:
iso:/cds/DragonNaturallySpeaking9dutch/dns9_cd1.iso
bash iso:/cds/DragonNaturallySpeaking9dutch/dns9_cd1.iso
nor any of the others I tried. Maybe I left something
off?


 
>     Tell us whether the iso protocol works without
Krusader
>     or not.

Trying Konq:
Opens with K3b.
Has an option to open ISO9669 View, but it doesn't do
anything --no error no action.

Same result in Krus, using the Konq menu actions.
Still works like before. In /cds directory ISO opens as
expected, but in ~/*.ISO only opens in K3b.  

Guess I'll stop K3b and try to leave nothing specified in
kcontrol.  That stopped K3b from always starting up.


So, I'm back where I started. Must be a permissions
thing.  Thanks for the suggestions.  I'll keep looking.

saludos,
Richard.


> Thanks,
>
> Csaba
>
>
>
> >
>


Re: [Krusader-devel] Re: In current cvs, iso files no longer open as vfs Karai Csaba 4/24/07 3:23 AM
>> 3. The first 2 point should solve the bug, if not, then
>>     try to enter the
>>
>>     iso:/path/myiso.iso/        URL.
>
> This was inconclusive. Nothing worked:
> iso:/cds/DragonNaturallySpeaking9dutch/dns9_cd1.iso
> bash iso:/cds/DragonNaturallySpeaking9dutch/dns9_cd1.iso
> nor any of the others I tried. Maybe I left something
> off?

In Krusader:
- enter the URL (top of the panel):
   iso:/path/name

In Konqueror:
- enter the URL (main URL):
   iso:/path/name

If it works, the mime type handling is buggy, if it doesn't work,
then the iso KIO slave is buggy.

Thanks,

     Csaba

Re: [Krusader-devel] Re: In current cvs, iso files no longer open as vfs Richard/g 4/24/07 5:34 AM
On Martes 24 Abril 2007, Karai Csaba wrote:
>
> >> 3. The first 2 point should solve the bug, if not,
then
> >>     try to enter the
> >>
> >>     iso:/path/myiso.iso/        URL.
> >
> > This was inconclusive. Nothing worked:
> > iso:/cds/DragonNaturallySpeaking9dutch/dns9_cd1.iso
> > bash
iso:/cds/DragonNaturallySpeaking9dutch/dns9_cd1.iso
> > nor any of the others I tried. Maybe I left something
> > off?
>
> In Krusader:
> - enter the URL (top of the panel):
>    iso:/path/name

Entered this url and path in the address bar of Krus:
/install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso

and the result:  
¡El directorio
/install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso
no existe!

> In Konqueror:
> - enter the URL (main URL):
>    iso:/path/name

Entered this url and path in the address bar of Konq:
/install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso

and the result:
brings up a dialog box to choose an application.

 
> If it works, the mime type handling is buggy, if it
doesn't work,
> then the iso KIO slave is buggy.

Well, after the above, checked permissions on both trees.
There were similar but could be the problem. They were
755 for richard all the way but at the top of one of the
trees there is still root as owner.

Had not changed owners, but returning to
/local/install/distros/debian/etch-4.0-r0
and pressing return on debian-40r0-i386-CD-1.iso
opened it as vfs.  Go figure.  Konqueror still opens the
app chooser dialog box on the same file. So perhaps the
Kde associations are not consistent?


Thanks for the ideas. Hope this helps in underderstanding
this gnarly knot.  It used to work flawlessly.

regards,
Richard.

 
> Thanks,
>
>      Csaba

And remember

Re: [Krusader-devel] Re: In current cvs, iso files no longer open as vfs Karai Csaba 4/25/07 5:33 AM
> Entered this url and path in the address bar of Krus:
> /install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso

Wrong. Enter:

iso:/install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso

> Entered this url and path in the address bar of Konq:
> /install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso

Wrong. Enter:

iso:/install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso

Bye,

     Csaba

Re: [Krusader-devel] Re: In current cvs, iso files no longer open as vfs Richard/g 4/25/07 9:54 AM
On Miércoles 25 Abril 2007, Karai Csaba wrote:
>
> > Entered this url and path in the address bar of Krus:
>
> /install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso
>
> Wrong. Enter:
>
>
iso:/install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso

OK.
Entered
iso:/install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso
in address bar of Krusader, with the following result:

El archivo o carpeta (file or dir)
distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso
no existe. (doesn't exist)

Tried this in all levels from / to ./

But the ISO will open by pressing return or d-clicking on
the file.

 
> > Entered this url and path in the address bar of Konq:
>
> /install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso
>
> Wrong. Enter:
>
>
iso:/install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso

And, Konqueror 3.5.6 says,
Load error produced,
iso:/install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso:
File doesn't exist.

isoView in Konq Actions is null --no error, no action.


Looks like a problem in Kde?
Thanks for your ideas.

regards,
Richard.

 
> Bye,
>
>      Csaba

Re: [Krusader-devel] Re: In current cvs, iso files no longer open as vfs Karai Csaba 4/25/07 11:01 AM

> Looks like a problem in Kde?
> Thanks for your ideas.
>
> regards,
> Richard.
>

No. can you please put the problematic file onto the internet (with a URL)?

I guess, that not every ISO file fails. I attach an iso file, can you
please check whether it's OK or not?

Thanks,

     Csaba


Re: [Krusader-devel] Re: In current cvs, iso files no longer open as vfs Richard/g 4/25/07 11:17 AM
On Mi=E9rcoles 25 Abril 2007, Karai Csaba wrote:
>
> > Looks like a problem in Kde?
> > Thanks for your ideas.
> >
> > regards,
> > Richard.
> >
>
> No. can you please put the problematic file onto the
internet (with= a URL)?

>
> I guess, that not every ISO file fails. I attach an iso
file, can you
> please check whether it's OK or not?

Entering this in the address bar:
iso:/install/distros/debian/etch-4.0-r0/test.iso
of Krus and Konq gives the same error message:
File or Dir does not exist.

All of the ISO files that I have tried give the same
error in both Krus and Konq when entered in the address
bar,
but they all will open in Krus with a double click or
when press Enter on the file, but now in Konq.
(I removed the Kde association with k3b, yesterday)
nor by ark. nor by Iso9660 View.

Maybe the ISO isn't defined in KDE. I know it is set in
Krus Konfigurator.

regards,
Richard.

> Thanks,
>
> Csaba

Re: [Krusader-devel] Re: In current cvs, iso files no longer open as vfs Karai Csaba 4/25/07 12:47 PM
> All of the ISO files that I have tried give the same
> error in both Krus and Konq when entered in the address
> bar,
> but they all will open in Krus with a double click or
> when press Enter on the file, but now in Konq.
> (I removed the Kde association with k3b, yesterday)
> nor by ark. nor by Iso9660 View.
>
> Maybe the ISO isn't defined in KDE. I know it is set in
> Krus Konfigurator.

Cannot understand why the file is not opened when entered as a URL,
but works with double click.

Double click means, that Krusader opens the iso://path/sg.iso URL.
It's impossible, that it works one time and not works in another one.


1.
The iso protocol is part of Krusader. If you don't install Krusader
properly, then iso protocol will not work. At least one make install
is required. Don't install Krusader to /usr/local as it won't work from
there.

The iso protocol was not written by us, but Krusader "imported" that
protocol. Nobody used it, that's why we put into the Krusader sources.

Now the iso protocol is maintained and developed by Krusader!

2.
I've downloaded the "debian-40r0-i386-CD-1.iso" from the net. It
opens correctly.

3.
Can you please try it as user "root"? If there are problems with the
permissions, then it'll work as root.

Thanks,

     Csaba

Re: [Krusader-devel] Re: In current cvs, iso files no longer open as vfs Richard/g 4/25/07 3:15 PM
On Miércoles 25 Abril 2007, Karai Csaba wrote:
>
> > All of the ISO files that I have tried give the same
> > error in both Krus and Konq when entered in the
address bar,
> > but they all will open in Krus with a double click or
> > when press Enter on the file, but now in Konq.

(this should read, but *not* in Konq)

> > (I removed the Kde association with k3b, yesterday)
> > nor by ark. nor by Iso9660 View.
> >
> > Maybe the ISO isn't defined in KDE. I know it is set
in Krus Konfigurator.
>
> Cannot understand why the file is not opened when
entered as a URL,
> but works with double click.
>
> Double click means, that Krusader opens the
iso://path/sg.iso URL.
> It's impossible, that it works one time and not works
in another one.

Yes, I've observed the same url path reflected in the
address bar when I double click an iso.

 
> 1.
> The iso protocol is part of Krusader. If you don't
install Krusader
> properly, then iso protocol will not work. At least one
make install
> is required. Don't install Krusader to /usr/local as it
won't work from
> there.

Now that may be a clue. I build with checkinstall:
$ make -f Makefile.cvs && make && su -c checkinstall

I'll try adding the "make install" step.  I've been
leaving it out as it didn't seem necessary.

> The iso protocol was not written by us, but
Krusader "imported" that
> protocol. Nobody used it, that's why we put into the
Krusader sources.
>
> Now the iso protocol is maintained and developed by
Krusader!
>
> 2.
> I've downloaded the "debian-40r0-i386-CD-1.iso" from
the net. It opens correctly.
>
> 3.
> Can you please try it as user "root"? If there are
problems with the permissions, then it'll work as root.

No joy.  As root,  
iso:/install/distros/debian/etch-4.0-r0/debian-40r0-i386-CD-1.iso
Gives the same error as before.  

But at least ISOs always open the vfs in Krus with
double-click or Enter on the file.

Thanks,
Richard.

> Thanks,
>
>      Csaba

Re: [Krusader-devel] Re: In current cvs, iso files no longer open as vfs Rafi Yanai 4/25/07 4:20 PM
Richard,

I might be missing something here, but right now, some *.iso files are opened while others do not ?
I re-read the entire thread and I'm not sure I understood the situation..

Can you please repeat the bug report in one message ?

Thanks,
Rafi.
Re: [Krusader-devel] Re: In current cvs, iso files no longer open as vfs Richard/g 4/25/07 4:45 PM
On Miércoles 25 Abril 2007, Rafi Yanai wrote:
> Richard,
>
> I might be missing something here, but right now, some
*.iso files are opened while others do not ?

Negative. At present, all iso's open in vfs in Krus when
double-clicking or press Enter, but NOT when enter the
URL in the address bar.  Not even in root.

At least it is working now for vfs.

> I re-read the entire thread and I'm not sure I
understood the situation..
>
> Can you please repeat the bug report in one message ?
>
> Thanks,
> Rafi.

Entering this in the address bar:
iso:/install/distros/debian/etch-4.0-r0/test.iso
or any other iso that I have, of Krus and Konq gives the

same error message:   File or Dir does not exist.

All of the ISO files that I have tried give the same

error in both Krus and Konq when entered in the address
bar,
but they all will open in Krus with a double click or
when press Enter on the file, but *not* in Konq.
(I removed the Kde association with k3b, yesterday, since
it would only open in k3b) nor by ark. nor by
Iso9660_View.

Karai suggested that Krusader might be badly installed.
I've been using checkinstall to build and compile leaving
a deb for reinstall, omitting the step of "make install"
which is handled, maybe not entirely well, by
checkinstall.

I am going to download from cvs and try installing
via "make install" before the checkinstall to see if I
can see a difference.  

I realize that checkinstall is not entirely kosher, but
it provides a deb that allows reinstalling without
having to rebuild.

Thanks,
Richard.