Firebug 2.0.2

Showing 1-18 of 18 messages
Firebug 2.0.2 Jan Honza Odvarko 7/18/14 2:21 AM
Re: Firebug 2.0.2 Tim Ryan 7/18/14 7:51 AM
Confirming that the Net tab issue wrt to filtering cached responses is fixed in this version.

Thanks!

On Friday, July 18, 2014 4:21:30 AM UTC-5, Jan Honza Odvarko wrote:
https://blog.getfirebug.com/2014/07/18/firebug-2-0-2/

Honza
Re: Firebug 2.0.2 Lomikar 7/18/14 11:53 AM
Hi Honza;

Breakpoints seem still to have issues:
1: The code vs breakpoints panes are getting out of sync.
2. Spinner sometimes doesn't go away.
3: And now function keys F8, F10, F11 and Ctrl/Shift+F11 don't do anything. Same by clicking on them in UI.

Thank you
Lumir
Re: Firebug 2.0.2 Sebastian Zartner 7/21/14 12:49 AM
Do you have test cases for these three points, so we can reproduce the problem?
Does the problem go away, if you create a new profile and just install Firebug in it?

Sebastian
Re: Firebug 2.0.2 Brian Merz 7/23/14 12:24 PM
This is fixed when a new profile is created and Firebug installed there.
Re: Firebug 2.0.2 Sebastian Zartner 7/25/14 1:08 AM
Ok, so it's either related to the profile settings or a conflict with other extensions. Can you please investigate this further following the steps described in our first aid page?

Sebastian
Re: Firebug 2.0.2 Richard Davies 8/8/14 8:11 AM
When the Firebug 2.0.2 script panel is enabled, it's causing extremely slow page loads (60+ seconds) and one or more "Unresponsive script" warnings to appear when loading a page that contains the ZingChart JavaScript library (ex. http://www.zingchart.com/gallery/). This issue wasn't present in v2.0.1.



On Friday, July 18, 2014 2:21:30 AM UTC-7, Jan Honza Odvarko wrote:
https://blog.getfirebug.com/2014/07/18/firebug-2-0-2/

Honza
Re: Firebug 2.0.2 Sebastian Zartner 8/8/14 2:02 PM
Thanks for the test case. I can reproduce that issue and reported it here:

https://code.google.com/p/fbug/issues/detail?id=7621

Sebastian
Re: Firebug 2.0.2 Richard Davies 8/8/14 2:14 PM
Thank you!
Re: Firebug 2.0.2 AJ123abc 8/11/14 11:35 PM
I just installed fresh 2.0.2 version of firebug into a fresh new profile (I even re-installed Firefox version 31 fresh).
The line numbers and the code that is displayed in Firebug are NOT in sync.
PLEASE HELP.
Thank you so much in advance
AJ
Re: Firebug 2.0.2 AJ123abc 8/11/14 11:51 PM
For me it continues to happen even with installing firebug (2.0.2) into a new profile... this was working fine with 2.0. I have a hard time finding from where I can go back to 2.0...?
Re: Firebug 2.0.2 Sebastian Zartner 8/12/14 3:02 AM
There are some problems regarding dynamic script display within the Script panel in Firebug 2.0.2. Instead of switching back to an earlier version of Firebug I suggest you wait for the next bug fix release (which should be this or next week).
If you want to switch back anyway, you can find all Firebug versions on addons.mozilla.org.

Sebastian
Re: Firebug 2.0.2 AJ123abc 8/12/14 2:21 PM
Frankly, I am baffled as how this works for anyone else...? Everyone in my team has the same issue with 2.0.2 where line numbers are not in sync with the code and hence making debugging literally impossible. We have tried uninstall/re-install into new profile,etc. (using FF version 31).
Anyway... we have switched back to version 1.12.8.

Also another issue with 2.0 is that, when adding a new variable to watch (under watch tab) it used to get added at the top of the list, now it is added at the bottom and user has to scroll down. Usually, you want to see the most recent added variables to watch at the top.

Regards,
Re: Firebug 2.0.2 Sebastian Zartner 8/13/14 12:14 AM
On Tuesday, August 12, 2014 11:21:46 PM UTC+2, AJ123abc wrote:
Frankly, I am baffled as how this works for anyone else...? Everyone in my team has the same issue with 2.0.2 where line numbers are not in sync with the code and hence making debugging literally impossible. We have tried uninstall/re-install into new profile,etc. (using FF version 31).
Could it be that besides posting here you also created issue 7625?
What do you actually mean with "line numbers are not in sync with the code"? Is it the same as described in issue 7615? If not, please provide a test case, so it can be reproduced what you mean.

Also another issue with 2.0 is that, when adding a new variable to watch (under watch tab) it used to get added at the top of the list, now it is added at the bottom and user has to scroll down. Usually, you want to see the most recent added variables to watch at the top.
FWIW this was reported earlier in another thread. You should create an issue for that.

Sebastian

On Tuesday, August 12, 2014 3:02:26 AM UTC-7, Sebastian Zartner wrote:
There are some problems regarding dynamic script display within the Script panel in Firebug 2.0.2. Instead of switching back to an earlier version of Firebug I suggest you wait for the next bug fix release (which should be this or next week).
If you want to switch back anyway, you can find all Firebug versions on addons.mozilla.org.

Sebastian

On Tuesday, August 12, 2014 8:51:08 AM UTC+2, AJ123abc wrote:
For me it continues to happen even with installing firebug (2.0.2) into a new profile... this was working fine with 2.0. I have a hard time finding from where I can go back to 2.0...?


On Friday, July 25, 2014 1:08:31 AM UTC-7, Sebastian Zartner wrote:
Ok, so it's either related to the profile settings or a conflict with other extensions. Can you please investigate this further following the steps described in our first aid page?

Sebastian

On Wednesday, July 23, 2014 9:24:59 PM UTC+2, Brian Merz wrote:
This is fixed when a new profile is created and Firebug installed there.

On Monday, July 21, 2014 12:49:31 AM UTC-7, Sebastian Zartner wrote:
Do you have test cases for these three points, so we can reproduce the problem?
Does the problem go away, if you create a new profile and just install Firebug in it?

Sebastian

On Friday, July 18, 2014 8:53:45 PM UTC+2, Lomikar wrote:
Hi Honza;

Breakpoints seem still to have issues:
1: The code vs breakpoints panes are getting out of sync.
2. Spinner sometimes doesn't go away.
3: And now function keys F8, F10, F11 and Ctrl/Shift+F11 don't do anything. Same by clicking on them in UI.

Thank you
Lumir
Re: Firebug 2.0.2 AJ123abc 8/14/14 3:53 PM
I just upgraded to 2.0.3, and I still see the issue where line numbers are not in sync with the actual code.
That is for example:

1: var x = 1;
2: if (x == 1) {
3:        someFunction(x);

In the debugger I see line 2 as being grayed out thus not able to set a break point on that line, But can do so on line 3. Except when the break point happens on line 3, it is actually executing line 2 (the IF statement).

This problem started happening in 2.0.2 and now in 2.0.3. It has impacted all my team badly. We keep switching back to 1.12.8, except FF magically keeps  upgrading us to the latest version of firebug (in spite of the fact we have specified NOT to upgrade us automatically)!
Re: Firebug 2.0.2 Sebastian Zartner 8/18/14 2:13 PM
I put your code into a simple test case, which I attached to this post. Using Firefox 31.0 + Firebug 2.0.3 on Win8.1.
The lines are correctly marked as executable, I can set a breakpoint at the line containing if (x == 1) { and it also gets it when I reload the page.

I assume you have a syntax error within your script. When there is a syntax error within a script, you may not be able to set a breakpoint in it. So please check whether there are any JavaScript errors shown within the Console panel (ensure you have the option Show JavaScript Errors checked).
If you can exclude syntax errors as the cause, please provide a complete test case and describe the steps to reproduce the problem.

Sebastian
Re: Firebug 2.0.2 Sebastian Zartner 8/18/14 2:18 PM
except FF magically keeps  upgrading us to the latest version of firebug (in spite of the fact we have specified NOT to upgrade us automatically)!
Did you uncheck the option Update Add-ons Automatically within the Add-ons Manager?

Sebastian
Re: Firebug 2.0.2 AJ123abc 8/18/14 10:20 PM
Thanks Sebastian...
Attached please find the screen shot of firebug version 2.0.3 where line numbers and code lines are not in sync.
I have show JavaScript errors, show css Errors, show JavaScript warnings turned on. No errors are displayed in  console  (hence I assume there are no errors).
And yet this is what I see in the debugger (please see attached file).
I really do not know how to reproduce the issue short of submitting our entire project (which we can not).
In the meantime we are switching back to 1.12.8.
Please advise.
Kindest Regards,
AJ