API Posts approve/remove sometimes doesn't work ?

Showing 1-5 of 5 messages
API Posts approve/remove sometimes doesn't work ? Alain B. 7/13/12 7:00 AM
Hi, 
I've noticed several occurences where our approve/remove requests to the "Posts" API doesn't do the job.
Is that a know problem ? Is it possible for you to investigate ?
I have the id of the post (forum "ftvi"), date and time (July 13th 14:11:47,271 French Time) of the call to http://disqus.com/api/3.0/posts/approve.json and response ({"code": 0, "response": [{"id": "586814491"}]}).
I have a screenshot of the Disqus moderation tool which shows the post is still in pending state (I can attach it if you want).

Cheers,
Alain


Re: API Posts approve/remove sometimes doesn't work ? Alain B. 7/17/12 11:45 PM
Please note that this kind of problem is occuring every day. 
Do you have some feedack about it ?

Cheers

Le vendredi 13 juillet 2012 16:00:34 UTC+2, Alain B. a écrit :
Re: [disqus-dev] Re: API Posts approve/remove sometimes doesn't work ? David Cramer 7/18/12 9:23 AM
What you're seeing is likely lag in the system. The API is powered off of replica databases for most things, which means actions may not take affect immediately. 
Re: API Posts approve/remove sometimes doesn't work ? Alain B. 7/18/12 10:41 AM
I thought it could be the reason at first, but after days the message status is still unapproved.
That is the case of the message I took as an example in my first post (id= 586814491). As of today it is still in unapproved state.
And it's not the only one.

Le vendredi 13 juillet 2012 16:00:34 UTC+2, Alain B. a écrit :
Hi, 
Re: API Posts approve/remove sometimes doesn't work ? Alain B. 8/28/12 12:08 AM
Hi,
Can we expect some work done on this bug ? What is the status of the investigation ?
The problem is still occurring randomly.

Alain