cbstats not working

Showing 1-5 of 5 messages
cbstats not working Guy 9/26/12 11:48 AM
Hi guys,

I'm trying to set up monitoring of a couchbase cluster (couchbase bucket running on standard port 11211 with SASL auth, default bucket was removed) and I'm having a problem using cbstats. I'm using the command outlined in the docs: but I get "Stats '' are not available from the requested engine" when I try to run it against our cluster.

I'm running this from one of the nodes in the cluster, I've confirmed that the bucket name and password I'm using are correct, I've tried both port 11210 and 11211 and I've tried the actual IP for the box as well as 'localhost' but it keeps giving me the error above.

Any idea what's going wrong here?


Re: cbstats not working Sergey Avseyev 9/26/12 11:53 AM
It might be off the topic, but libcouchbase provides `cbc' tool, which
also have `stats' subcommand, which returns stats for all nodes in the

Here is the example of usage:

The libcouchbase isn't included in server package.

Sergey Avseyev
Re: cbstats not working Guy 9/26/12 11:59 AM
Oops... I just realised my mistake. I wasn't using the -b and -p flags to specify the bucket name and password. In my defense, the documentation page I was looking at doesn't appear to document these flags or indicate they need to be used, even on the following page where specific bucket stats are retrieved:

Anyway, problem solved. Thanks for your reply, Sergey.

Re: cbstats not working Zeming Jin 9/26/12 12:01 PM
Did you use '-b [bucket name] -p [bucket password]' as part of the command line?

Re: cbstats not working Guy 9/27/12 12:52 PM
Oh wait - that's wrong. It *does* show these command line parameter options on the next page. Anyway, problem solved :)