Gawk 4.1.0 released

Showing 1-9 of 9 messages
Gawk 4.1.0 released none 5/10/13 4:08 AM
Greetings all.

This note announces the next major release of GNU Awk: version 4.1.0.

The following files may be retrieved from ftp://ftp.gnu.org/gnu/gawk,
or via HTTP from http://ftp.gnu.org/gnu/gawk:

-rw-r--r--    1 3003     3002          490 May 10 09:50 gawk-4.1.0.tar.xz.sig
-rw-r--r--    1 3003     3002      2049080 May 10 09:50 gawk-4.1.0.tar.xz
-rw-r--r--    1 3003     3002          490 May 10 09:49 gawk-4.1.0.tar.gz.sig
-rw-r--r--    1 3003     3002      3995528 May 10 09:49 gawk-4.1.0.tar.gz

This is a major new release, with a number of new features.  The relevant
part of the NEWS file is appended below.

This release represents close to two years of very hard work by a number
of people.  I thank them all for their contributions, I could not have
done it by myself.

Differences from gawk 4.0.2 are not available; they would be too large.

The usual GNU build incantation should be used:

        tar -xpvzf gawk-4.1.0.tar.gz
        cd gawk-4.1.0
        ./configure && make && make check

Bug reports should be sent to bug-...@gnu.org.

Enjoy!

Arnold Robbins (on behalf of all the gawk developers)
arn...@skeeve.com
------------------------------------------------------------
Changes from 4.0.2 to 4.1.0
---------------------------

1. The three executables gawk, pgawk, and dgawk, have been merged into
   one, named just gawk.  As a result:
           * The -R option is gone
        * Use -D to run the debugger. An optional file argument is a
          list of commands to run first.
        * Use -o to do pretty-printing only.
        * Use -p to do profiling.
   This considerably reduces gawk's "footprint" and eases the documentation
   burden as well.

2. Gawk now supports high precision arithmetic with MPFR.  The default is
   still double precision, but setting PREC changes things, or using
   the -M / --bignum options.  This support is not compiled in if the MPFR
   library is not available.

3. The new -i option (from xgawk) is used for loading awk library files.
   This differs from -f in that the first non-option argument is treated
   as a script.

4. The new -l option (from xgawk) is used for loading dynamic extensions.

5. The dynamic extension interface has been completely redone!  There is
   now a defined API for C extensions to use.  A C extension acts like
   a function written in awk, except that it cannot do everything that awk
   code can. However, this allows interfacing to any facility that is
   available from C.  This is a major development, see the doc, which has
   a nice shiny new chapter describing everything.

   This support is not compiled in if dynamic loading of shared libraries
   is not supported.

   The old extension mechanism is still supported for compatiblity, but
   it will most definitely be removed at the next major release.

6. The "inplace" extension, built using the new facility, can be used to
   simulate the GNU "sed -i" feature.

7. The and(), or() and xor() functions now take any number of arguments,
   with a minimum of two.

8. New arrays: SYMTAB, FUNCTAB, and PROCINFO["identifiers"]. SYMTAB allows
   indirect access to any defined variable or array; it is possible to
   "walk" the symbol table, if that should be necessary.

9. Support for building gawk with a cross compiler has been improved.

10. Infrastructure upgrades: bison 2.7.1, gettext 0.18.2.1, automake 1.13.1,
    libtool 2.4.2 for the extensions.
--
Aharon (Arnold) Robbins                         arnold AT skeeve DOT com
P.O. Box 354                Home Phone: +972 8 979-0381
Nof Ayalon
D.N. Shimshon 9978500        ISRAEL
Re: Gawk 4.1.0 released mjc 5/15/13 9:31 AM
Sounds great.

How should I install it on Mac os x? I use macports, but pretty blindly.

The current version is 4.0.2.

Or should I wait till this gets incorporated into macports?

Thanks,

Martin Cohen
mjc...@acm.org
Re: Gawk 4.1.0 released Kenny McCormack 5/15/13 10:56 AM
In article <e373e792-1b7e-45f1-b095-0a8ec1bf4f71@googlegroups.com>,
mjc  <martin...@gmail.com> wrote:
>Sounds great.
>
>How should I install it on Mac os x? I use macports, but pretty blindly.
>
>The current version is 4.0.2.
>
>Or should I wait till this gets incorporated into macports?

I'm in the same boat.  For a long, long, long time, I resisted installing gcc on my
Mac, but eventually, I bit the bullet and did it.  It wasn't so bad.  You just go to
apple.com and search around for Xcode, then clickety, clickety, clickety click and
wait, wait, wait, wait, but eventually, it gets done.

I've only used it for compiling GNU and other command line stuff; I haven't gotten
into any Mac-specific or GUI stuff yet.  But it works fine for compiling GAWK and
other such toys.  I recommend it to you.

--
"That's the eternal flame."[7] The single became another worldwide hit.[8]

Hoffs was actually naked when she recorded the song, after being convinced
by Sigerson that Olivia Newton-John got her amazing performances by
recording everything while naked.[9]

(From: http://en.wikipedia.org/wiki/The_Bangles)

Re: Gawk 4.1.0 released Hermann Peifer 5/15/13 2:09 PM
On 2013-05-15 14:56, Kenny McCormack wrote:
> In article <e373e792-1b7e-45f1-b095-0a8ec1bf4f71@googlegroups.com>,
> mjc  <martin...@gmail.com> wrote:
>> Sounds great.
>>
>> How should I install it on Mac os x? I use macports, but pretty blindly.
>>
>> The current version is 4.0.2.
>>
>> Or should I wait till this gets incorporated into macports?
>
> I'm in the same boat.  For a long, long, long time, I resisted installing gcc on my
> Mac, but eventually, I bit the bullet and did it.  It wasn't so bad.  You just go to
> apple.com and search around for Xcode, then clickety, clickety, clickety click and
> wait, wait, wait, wait, but eventually, it gets done.
>

The OP is using MacPorts, so he should have Xcode already, as it is
mentioned as prerequisite #1 on the MacPorts installation page,
http://www.macports.org/install.php

So what is left to do is to follow the instructions in Arnold's initial
post.


Hermann
Re: Gawk 4.1.0 released Kenny McCormack 5/15/13 3:16 PM
In article <kn0tib$8mg$1...@news.albasani.net>,
OK.  I looked at MacPorts once and a) Didn't see the point of it and b) Thought it
looked weird and complicated.

So, what is the point of a "ports" repository if you need to have the compiler (and
know how to use it) yourself anyway - i.e., couldn't you just compile your own stuff
and not bother with the repository?

Anyways, that's what I do...

--
Modern Christian: Someone who can take time out from
complaining about "welfare mothers popping out babies we
have to feed" to complain about welfare mothers getting
abortions that PREVENT more babies to be raised at public
expense.
Re: Gawk 4.1.0 released Aharon Robbins 5/15/13 10:48 PM
In article <e373e792-1b7e-45f1-b095-0a8ec1bf4f71@googlegroups.com>,
mjc  <martin...@gmail.com> wrote:
>Sounds great.
>
>How should I install it on Mac os x? I use macports, but pretty blindly.
>
>The current version is 4.0.2.
>
>Or should I wait till this gets incorporated into macports?
>
>Thanks,
>
>Martin Cohen
>mjc...@acm.org

As has been pointed out, if you have a compiler and make installed,
the standard recipe works:

        wget http://ftp.gnu.org/gnu/gawk/gawk-4.1.0.tar.gz
        tar -xpzvf gawk-4.1.0.tar.gz
        cd gawk-4.1.0
        ./configure && make && make check
        sudo make install        # or whatever, I think it's sudo

The new extension mechanism is even supported.

Arnold
Re: Gawk 4.1.0 released Edward Rosten 5/17/13 9:12 AM
On Wed, 15 May 2013 22:16:25 +0000, Kenny McCormack wrote:

>
> OK.  I looked at MacPorts once and a) Didn't see the point of it and b)
> Thought it looked weird and complicated.
>
> So, what is the point of a "ports" repository if you need to have the
> compiler (and know how to use it) yourself anyway - i.e., couldn't you
> just compile your own stuff and not bother with the repository?

Getting a bit OT, but the ports repository does dependency tracking. So,
presumably if you told it to install gawk, it would first make sure MPFR
is compiled and installed. it makes it less hassle to install programs
with many dependencies, since you don't need to plough through the
documentation to see what it's necessary to install, then make sure those
are all done in the correct order.


-Ed
Re: Gawk 4.1.0 released Kenny McCormack 5/17/13 10:00 AM
In article <kn5kt0$nr2$1...@dont-email.me>,
But MPFR is *not* a dependency for compiling/installing GAWK.

It works just fine without it.

--
Is God willing to prevent evil, but not able? Then he is not omnipotent.
Is he able, but not willing? Then he is malevolent.
Is he both able and willing? Then whence cometh evil?
Is he neither able nor willing? Then why call him God?
~ Epicurus

Re: Gawk 4.1.0 released Edward Rosten 5/20/13 5:13 AM
On Fri, 17 May 2013 17:00:34 +0000, Kenny McCormack wrote:

>
> But MPFR is *not* a dependency for compiling/installing GAWK.
>
> It works just fine without it.

It's an optional dependency now, IIRC. But anyway, I was using an awk
specific example. For ImageMagick/Netpbm, it would ensure that libjpeg,
libpng, libtiff etc are all compiled and installed. That library has
quite a large number of both optional and non-optional dependencies.

I have used it before (though I do not currently) and if you are going to
be installing a large number of source packages it is considerably less
faffy than doing it by hand. It also has a upgrade feature so you can
automatically compile and install the latest packages. Though when I used
it, the mac versions were sufficiently brittle as to be nearly not worth
using. The OpenBSD one worked fine though.

-Ed