Categories: BeagleBoard-xM : Software :

Play video is very slow by using Qt + Phonon + Gstreamer

Showing 1-3 of 3 messages
Play video is very slow by using Qt + Phonon + Gstreamer William 5/23/12 6:57 PM

Hi All,

I'm trying to make a media player using Qt. I found that it's very slow after trying several methods, includes Qt5 alpha + Gstreamer, Qt5 alpha + Qt mobility 1.2.0 + Gstreamer, Qt 4.8.1 + Qt mobility 1.2.0 + Gstreamer, Qt 4.8.2 + Phonon  + Gstreamer. My environment is as follow:

Beagleboard-xM

TI DVSDK 4.01.00.09 for DM3730

Qt 4.8.2 + Phonon + Gstreamer


It play very well when I used the gstreamer directly:

gst-launch filesrc location="/usr/share/ti/data/videos/davincieffect_h264_aac.mp4" ! qtdemux name=demux demux.audio_00 ! queue max-size-buffers=8000 max-size-time=0 max-size-bytes=0 ! TIAuddec1 ! alsasink demux.video_00 ! queue ! TIViddec2 padAllocOutbufs=TRUE ! TIDmaiVideoSink videoStd=720P_60 videoOutput=AUTO numBufs=5

Re: Play video is very slow by using Qt + Phonon + Gstreamer tripzero 5/24/12 11:20 AM
Have you tried QGstreamer?  You should be able to construct the same pipeline as the one above using QGStreamer directly.

 
Re: Play video is very slow by using Qt + Phonon + Gstreamer William 5/24/12 8:46 PM
Yes, I tried and it works OK. I also try to comment code related on playbin in Qt and create the gstreamer pipeline manually. When I connect to TIDmaiVideoSink, it plays very well. But it plays very slow when I change video ouput from TIDmaiVideoSink to QVideoWidget.

在 2012年5月25日星期五UTC+8上午2时20分34秒,tripzero写道: