Google Groups

Gravity Forms, Custom Post Types, and Taxonomies


John Chandler Apr 6, 2012 8:48 AM
Posted in group: WordPress Austin
Hi all,

I've built a directory site where members can post their own directory listing using a Gravity Form posting to a Custom Post Type (called directory) via the Gravity Forms & Custom Post Types Plugin. Everything works fine, except the Custom Taxonomies I have setup as part of the form. If I post to the form while logged in as admin, the taxonomies are properly assigned. But if I use the form logged in as any other level (Editor and below), the taxonomies aren't assigned. However, I can assign taxonomies to the post from the backend, so there are rights in place to at least edit them. Here's the different steps I've tried in troubleshooting:

1) I've tried using both a custom capability called 'directory' as well just using the 'post' capability for the custom post type. 
2) I've left the capabilities on the taxonomy set to default, and I've also tried assigning them to 'publish_posts', i.e.
    'capabilities' => array (
   'manage_terms' => 'publish_posts',
   'edit_terms' => 'publish_posts',
   'delete_terms' => 'publish_posts',
   'assign_terms' => 'publish_posts'
                ),
3) I've tried hitting my keyboard with a hammer.

This site was ready to launch and this problem appeared in final testing, so I'd love to sort it out. Anyone have any ideas what might be causing my problem?

John Chandler
twitter: @johnchandler