Google Groups

Re: building vim with ruby support

Jason Felice Dec 23, 2011 6:58 AM
Posted in group: vim_mac
When vim builds against a ruby, that will be the ruby it uses regardless
of rvm or rbenv - so you'll not be able to switch.

I've not had luck building against a non-system ruby, though a co-worker
was able to do it.


On 12/23/11 1:15 AM, K H wrote:
> Hi,
> I'm on 10.7.2 with Xcode 4.2.1 and switch between system ruby 1.8.7
> (2010-01-10 patch level 249) and use rbenv to manage 1.9.3-p0.
> When I build vim (downloaded today from vim website) and ./configure
> --enable-rubyinterp while using 1.8.7 it builds find, and vim
> --version shows +ruby.
> But when I build vim with 1.9.3 it builds fine, but vim --version
> shows -ruby.
> Would I run into problems if I build vim with 1.8.7 but use it to work
> with 1.9.3?
> Thanks!
> Ken
> --
> You received this message from the "vim_mac" maillist.
> Do not top-post! Type your reply below the text you are replying to.
> For more information, visit