Google Groups

Re: [play-framework] '[1.2.4] error deploying app to gae [1.4.0] / [1.6.0]


Tom Carchrae Apr 26, 2012 5:44 AM
Posted in group: play-framework
that is a java compiler class version error.  you need to use jdk 6
and it looks like you're using jdk 5 somewhere.

i'd recommend using the oracle jdk 6.  openjdk is fine most of the
time, but not all the time. :)


tom

On Wed, Apr 25, 2012 at 10:14 PM, sas <ope...@gmail.com> wrote:
> I'm trying to deploy this app to gae (it's the spanish translation of
> play 1.x, here's it's runnign on gae: http://playdoces-opensas.rhcloud.com/)
>
> I tried with gae module 1.4.0, with the sdk 1.4.0, and with the modeul
> 1.6.0, with gae sdk 1.6.0 and 1.6.5
>
> In every case I get the same error:
>
> 2012-04-25 22:10:00.962
> play.Logger info: Starting /base/data/home/apps/s~playdocestest/prod.
> 358473253405297806/WEB-INF/application
> W 2012-04-25 22:10:00.962
> play.Logger warn: No tmp folder will be used (cannot create the tmp
> dir)
> I 2012-04-25 22:10:00.965
> play.Logger info: Module gae is available (/base/data/home/apps/
> s~playdocestest/prod.358473253405297806/WEB-INF/application/modules/
> gae-1.6.0)
> C 2012-04-25 22:10:01.151
> Uncaught exception from servlet
> java.lang.UnsupportedClassVersionError: DocViewerPlugin : Unsupported
> major.minor version 51.0
>        at com.google.appengine.runtime.Request.process-
> e8af6365e958593d(Request.java)
>        at java.lang.ClassLoader.defineClass1(Native Method)
>        at java.lang.ClassLoader.defineClass(ClassLoader.java:174)
>        at
> play.classloading.ApplicationClassloader.loadApplicationClass(ApplicationClassloader.java:
> 118)
>        at
> play.classloading.ApplicationClassloader.getAllClasses(ApplicationClassloader.java:
> 401)
>        at play.Play.preCompile(Play.java:570)
>        at play.Play.init(Play.java:299)
>        at play.server.ServletWrapper.contextInitialized(ServletWrapper.java:
> 77)
>        at
> org.mortbay.jetty.handler.ContextHandler.startContext(ContextHandler.java:
> 548)
>        at org.mortbay.jetty.servlet.Context.startContext(Context.java:136)
>        at
> org.mortbay.jetty.webapp.WebAppContext.startContext(WebAppContext.java:
> 1250)
>        at
> org.mortbay.jetty.handler.ContextHandler.doStart(ContextHandler.java:
> 517)
>        at org.mortbay.jetty.webapp.WebAppContext.doStart(WebAppContext.java:
> 467)
>        at
> org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:
> 50)
>        at com.google.tracing.TraceContext
> $TraceContextRunnable.runInContext(TraceContext.java:449)
>        at com.google.tracing.TraceContext$TraceContextRunnable
> $1.run(TraceContext.java:455)
>        at com.google.tracing.TraceContext.runInContext(TraceContext.java:
> 695)
>        at com.google.tracing.TraceContext
> $AbstractTraceContextCallback.runInInheritedContextNoUnref(TraceContext.java:
> 333)
>        at com.google.tracing.TraceContext
> $AbstractTraceContextCallback.runInInheritedContext(TraceContext.java:
> 325)
>        at com.google.tracing.TraceContext
> $TraceContextRunnable.run(TraceContext.java:453)
>        at java.lang.Thread.run(Thread.java:679)
>
> --
>
> seems like there some trouble with the DocViewer plugin
>
> DocViewerPlugin : Unsupported major.minor version 51.0
>
> Anybody else had a similar trouble?
>
> saludos
>
> sas
>
> --
> You received this message because you are subscribed to the Google Groups "play-framework" group.
> To post to this group, send email to play-fr...@googlegroups.com.
> To unsubscribe from this group, send email to play-framewor...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/play-framework?hl=en.
>