Google Groups

Re: [2.1-scala] Deploy 2.1 snapshot on Heroku : Dependencies failed

Jean Helou Oct 11, 2012 12:17 PM
Posted in group: Play Framework
Here is the exact error : 
[error] sbt.IncompatiblePluginsException: Binary incompatibility in plugins detected.
[error] Note that conflicts were resolved for some dependencies:
[error] com.typesafe.akka:akka-actor
[error] org.slf4j:slf4j-api
[error] io.netty:netty
[error] commons-codec:commons-codec
[error] org.apache.httpcomponents:httpcore
[error] org.apache.httpcomponents:httpclient
[error] asm:asm
[error] asm:asm-tree
[error] asm:asm-util
[error] org.avaje:ebean
[error] jline:jline
[error] junit:junit
[error] com.jcraft:jsch
[error] commons-logging:commons-logging
[error] Use 'last' for the full log.

On Thursday, October 11, 2012 9:13:09 PM UTC+2, Jean Helou wrote:
Hello peter

thanks for the fast answer, the weird thing is :  I do have a 0.12.1 sbt-launcher 

And I am trying to bootstrap a very basic project. all I have in it for the  moment is a project folder with

project/plugins.sbt looks like

resolvers += "Typesafe SNAPSHOT repository" at ""

resolvers += Resolver.url("Typesafe ivy SNAPSHOT repository", url(""))(Resolver.ivyStylePatterns)

resolvers += "Typesafe repository" at ""

scalaVersion := "2.9.2"

addSbtPlugin("play" % "sbt-plugin" % "2.1-SNAPSHOT")

I tried specifying scalaVersion to 2.10.0-M7 but  I haven't found an sbt-plugin version for 2.10 (even tried +publish local from master to no avail the plugin itself is not cross compiled) thus I changed it back to 2.9.2

my Build.scala
import sbt._
import PlayProject._
import Keys._

object ApplicationBuild extends Build {

  val appName = "Test play 2.1"
  val appVersion = "1.0"

  val scalaVersion = "2.10.0-M7"

  val appDependencies = { Seq() }

  val main = PlayProject(appName, appVersion, appDependencies, mainLang = SCALA)


sbt.version = 0.12.1

On Thursday, October 11, 2012 8:36:16 PM UTC+2, peter hausel wrote:
all you need is a compatible[1] sbt launcher (the play downloadable package is just convenience)

[1] play master: sbt 0.12.1 2.0.x sbt 0.11.3

On Thursday, October 11, 2012 2:23:05 PM UTC-4, Jean Helou wrote:
I just hit the same snafu trying to create a play2.1 application "from scratch" (as per without having play installed) 

Did you find a solution ?


On Sunday, September 30, 2012 5:19:54 PM UTC+2, Julien L. wrote:

I'm trying to deploy my Play2.1-Snapshot project on Heroku, but i'm facing problem with dependency resolving.
I've the same error when i run `sbt` in local.

sbt.IncompatiblePluginsException: Binary incompatibility in plugins detected. (full stacktrace

I've upgraded my plugins.sbt with the following lines to add snapshot compatibily. Is there anything else I must do ?

resolvers += "Typesafe repository" at ""
resolvers += Resolver.url("Typesafe Ivy Snapshots", url(""))(Resolver.ivyStylePatterns)
resolvers += "Typesafe snapshots" at "
addSbtPlugin("play" % "sbt-plugin" % "2.1-SNAPSHOT")

 Thanks for your help !