Google Groups

Re: [Omnetpp-l] Re: Register_Class() problem still exists in OMNeT++ 4.2.1 and MiXiM 2.2.1


Rudolf Hornig Feb 2, 2012 1:44 AM
Posted in group: omnetpp
- Have you compiled INETMANET successfully (i.e. is the libinet.dll present in the src directory).
- Are you trying to run the example from the mingwenv.cmd command prompt?

Rudolf

On Thu, Feb 2, 2012 at 6:12 AM, Jaipal Dhobale <dhobale...@gmail.com> wrote:
Dear Oudam,

I am facing following problem, could U please help me to get out of this in detail as I didn't have that much knowledge about OMNEt++ & INET/Inetmanet.

Please!!!! 

I am currently Using OMNet++4.2.1 (I have older version of Omnet++ 
4.1) My Omnetp++4.2.1 is running all samples examples provided by the 
supplier. To Create wired Computer Network simulation to test certain 
parameters I downloaded "Inetmanet". Now while running the Examples 
form Inetmanet command prompt displays following message. 

"<!> warning : Opp_run : Cannot check library ../../src/inet: The 
specified module could not be found 
OMNeT++ Discrete Event Simulation (c) 1992-2011 Andras Varga, OpenSim 
Ltd. 
Version: 4.2.1, build: 120118-94e2a29, edition: Academic Public 
License -- NOT FOR COMMERCIAL USE 
See the license for distribution terms and warranty disclaimer 
<!> Error during startup: Cannot load library '../../src// 
libinet.dll': The operation completed successfully." 

Now What do I do? to get out of this situation. Please help me. 

Regards, 
Mr.Jai


On Thu, Feb 2, 2012 at 1:03 AM, Oudam <oudam.r...@gmail.com> wrote:
My problem is solved by compiling both MiXiM and the simulation model
in release mode.
For that, I have done as follows:
- Instead of importing MiXiM as an projet into OMNeT++, I first creat
an omnet++ projet and choose gcc-release in Select Configuration.
Afterwards, I copy the files from MiXiM directory into the project.
The files package.ned may need to be modified.
- I do the same for my simulation model.

It works now !
I hope that may help, and am interessted by an esier way to do that.
Thanks in advance.




On 1 fév, 14:41, Oudam <oudam.ream....@gmail.com> wrote:
> Hi all,
>
> My simulation have  worked fine with omnet++ 4.1 and mixim 2.1 in
> Tkenv or console mode.
>
> I have ported my simulation code from omnet++ 4.1 and mixim 2.1 to
> omnet++ 4.2.1 and mixim 2.2.1.
> The porting itself seems to be ok (no compilation error) , but while
> executing simulation in Tkenv or console mode,
> I get this error :
> --- begin ---
> <!> Error in module (cCompoundModule) NetworkModel (id=1) during
> network setup: Class "MyWorldUtilityStats" not found -- perhaps its
> code was not linked in, or the class wasn't registered with
> Register_Class(), or in the case of modules and channels, with
> Define_Module()/Define_Channel().
> --- end ---
>
> In addition, mixim can not can not be build with realease mdoe : In
> Tkenv, gcc-release mode is not available.
> (Maybe the problem can be solve if I could build mixim in release
> mode).
> I used only 'make'  to build omnet++ 4.2.1.
>
> Anyone has any idea to solve these problems ?
> Thanks in advance.
>
> Oudam
>
> my machine:
> $ lsb_release -a
> No LSB modules are available.
> Distributor ID: Debian
> Description:    Debian GNU/Linux 6.0.3 (squeeze)
> Release:        6.0.3
> Codename:       squeeze

--
Sent from the OMNeT++ mailing list. To configure your membership,
visit http://groups.google.com/group/omnetpp



--
Regards
Mr. Dhobale J V

--
Sent from the OMNeT++ mailing list. To configure your membership,
visit http://groups.google.com/group/omnetpp