Google Groups

Re: type_conv/ocaml4 release


Anil Madhavapeddy Sep 6, 2012 2:35 PM
Posted in group: ocaml-core
On 8 Jul 2012, at 19:02, Markus Mottl <markus...@gmail.com> wrote:

> On Sun, Jul 8, 2012 at 5:12 PM, Anil Madhavapeddy <an...@recoil.org> wrote:
>> Also, is it necessary to have warnings-are-errors enabled in the released tarballs? It makes it awkward to test out new compiler versions, which usually introduce new ones every release.
>
> I agree with Anil that warnings-as-errors should not be enabled in
> releases, only during development work.


The latest pre-release Core tarballs also fail to compile under Homebrew/MacOS X (OCaml-4.00) due to warnings-as-errors still being activated on release tarballs.  Have you considered disabling this on release tarballs?

-anil