Google Groups

Re: [mongodb-user] Re: Sharding auth unauthorized problem


Barrie Apr 24, 2012 2:12 PM
Posted in group: mongodb-user
Is there anything in the logs that confirms that there's a problem with authentication? 

On Tuesday, April 24, 2012 3:21:10 AM UTC-4, Kroniak wrote:
I have same account in config db and in my db on both shard server in local collections.
It was not fix issue. 

суббота, 21 апреля 2012 г., 2:31:35 UTC+4 пользователь Barrie написал:
Kroniak,

Can you connect to the primary shard for that db and call db.system.users.find()?  You can find out the primary db for the shard by calling db.printShardingStatus() from mydb.

Barrie 

On Thursday, April 19, 2012 4:00:51 AM UTC-4, Kroniak wrote:
Yes, I have user which have full access to db config, and my dbs. 
In other our java application we dont have this issue.

in mongo shell I see:

./mongo mydb
mongo>db.auth('','');
mongo>1
mongo> db
mongo> mydb
mongo>var p = db.packets.find();
mongo>unauthorized


среда, 18 апреля 2012 г., 19:04:17 UTC+4 пользователь Sammaye написал:
This may sound like a dumb question but have you made sure the user your using the access the shards have permissions and are correctly indentified?

2012/4/18 Kroniak <guit...@gmail.com>
version 2.0.4

среда, 18 апреля 2012 г., 15:22:33 UTC+4 пользователь Kroniak написал:
Hi.

I have problem with authorize to shard mongo servers.

When I tried run "var p = db..find();" in mongo shell after successful
auth to mongos I got "unauthorized".
When I tried to connect to server from Jasper Report Server I got
"unathorized java exception" on DBCursor fetch.

Without --auth or --keyfile I dont have this issue.

Can anybody help me?

--
You received this message because you are subscribed to the Google Groups "mongodb-user" group.
To view this discussion on the web visit https://groups.google.com/d/msg/mongodb-user/-/onaT3TWA1mcJ.

To post to this group, send email to mongod...@googlegroups.com.
To unsubscribe from this group, send email to mongodb-user...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/mongodb-user?hl=en.