Google Groups

Re: [mongodb-user] help!addshard not work with auth


Eliot Horowitz Apr 26, 2012 5:06 AM
Posted in group: mongodb-user
Are you sure the mongos can talk to those machines?
Can you try connecting via the shell from the machine running mongos?

On Thu, Apr 26, 2012 at 7:26 AM, 超 王 <wangch...@gmail.com> wrote:
> i use replicaSet+mongos+configSvr. with option --keyFile;  (every
> server use the same keyfile)
>
> it looks ok when i enter replica set or mongo server. see below....
>
> mongos output:************************************
>> use admin
> switched to db admin
>> db.auth('sa','sa');
> 1
> mongos> use admin
>
>
> replicaset outout:**************************************
>> use admin
> switched to db admin
>> db.auth('sa','sa');
> 1
> SECONDARY>
> *******************************************************************************
> MY PROBLEM::::
>          when i enter mongos and do addshard  it tell me,so how can i
> solve the problem. or it is a bug? :
> --------------------------------------------------------------------------------------------------------------------------------
> Array
> (
>    [ok] => 0
>    [errmsg] => couldn't connect to new shard mongos connectionpool:
> connect failed
> set477985/58.215.164.196:16858,58.215.164.113:32948,58.215.176.110:18244 :
> connect failed to set
> set477985/58.215.164.196:16858,58.215.164.113:32948,58.215.176.110:18244
> )
> ----------------------------------------------------------------------------------------------------------------------------------
>
> thank you~
>
> --
> You received this message because you are subscribed to the Google Groups "mongodb-user" group.
> To post to this group, send email to mongod...@googlegroups.com.
> To unsubscribe from this group, send email to mongodb-user...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/mongodb-user?hl=en.
>