Google Groups

[ERROR] Unable to start App Engine server - On Ubuntu 11.10, Eclipse 3.7,


John Turnbull Feb 28, 2012 1:51 PM
Posted in group: Google Plugin for Eclipse
I have a clean build of a first sample webapp project that can't find the appengine.

I've tried updating the SDK to 1.6.3 and failed -- I understand others have the same problem.

I had problems with permissions in the appengine*.jar folder but I belief I have the -javaagent set correctly in the VM arguments field of the launch configuration properties.

What should I try next? Thanks!

Here's the console message:

----------------

Initializing App Engine server
   [WARN] ********************************************************
There is a new version of the SDK available.
-----------
Latest SDK:
Release: 1.6.3
Timestamp: Tue Jan 31 12:54:06 PST 2012
API versions: [1.0]

-----------
Your SDK:
Release: 1.6.1
Timestamp: Mon Dec 12 14:53:13 PST 2011
API versions: [1.0]

-----------
Please visit http://code.google.com/appengine for the latest SDK.
********************************************************

   [ERROR] Unable to start App Engine server
java.lang.RuntimeException: Unable to restore the previous TimeZone
at com.google.appengine.tools.development.DevAppServerImpl.restoreLocalTimeZone(DevAppServerImpl.java:228)
at com.google.appengine.tools.development.DevAppServerImpl.start(DevAppServerImpl.java:164)
at com.google.appengine.tools.development.gwt.AppEngineLauncher.start(AppEngineLauncher.java:97)
at com.google.gwt.dev.DevMode.doStartUpServer(DevMode.java:509)
at com.google.gwt.dev.DevModeBase.startUp(DevModeBase.java:1068)
at com.google.gwt.dev.DevModeBase.run(DevModeBase.java:811)
at com.google.gwt.dev.DevMode.main(DevMode.java:311)
Caused by: java.lang.NoSuchFieldException: defaultZoneTL
at java.lang.Class.getDeclaredField(Unknown Source)
at com.google.appengine.tools.development.DevAppServerImpl.restoreLocalTimeZone(DevAppServerImpl.java:222)
... 6 more
Unable to start embedded HTTP server[ERROR] shell failed in doStartupServer method

com.google.gwt.core.ext.UnableToCompleteException: (see previous log entries)
at com.google.appengine.tools.development.gwt.AppEngineLauncher.start(AppEngineLauncher.java:102)
at com.google.gwt.dev.DevMode.doStartUpServer(DevMode.java:509)
at com.google.gwt.dev.DevModeBase.startUp(DevModeBase.java:1068)
at com.google.gwt.dev.DevModeBase.run(DevModeBase.java:811)
at com.google.gwt.dev.DevMode.main(DevMode.java:311)