Google Groups

Re: RedCloth Warning


Fabio Cevasco Jul 30, 2010 4:49 AM
Posted in group: Glyph
Here, try installing this gem (generated right now from glyph/master):

http://groups.google.com/group/glyph-framework/web/glyph-0.3.0_20100730.gem

On Jul 30, 1:45 pm, h3raLd <h3r...@gmail.com> wrote:
> Yes, I noticed the problem a while ago... incorrect exception
> handling: an error of some kind occurred, but it's treated like a
> LoadError.
>
> Here's what you can do to fix the problem:
>
> -- Run Glyph in debug mode (this should show more details on the
> actual error): glyph --debug compile.
> -- Download the latest source from github and use that: I should have
> fixed that error a while ago (run rake install to create a new gem
> file and then install it).
> -- Wait until the next release (most likely sometime next month) or
> fix (I didn't plan any, but if you want I can send you an updated .gem
> file).
>
> Hope it helps!
>
> On Jul 30, 1:33 pm, carlskii <carl.bou...@gmail.com> wrote:
>
> > Hi,
>
> > Whenever I run a compile, Glyph seems that RedCloth is not installed.
> > I'm running OSX and it definitely there:
>
> > warning: RedCloth gem not installed. Please run: gem install RedCloth
> >     source: test.textile
>
> > *** LOCAL GEMS ***
>
> > actionmailer (2.3.8, 2.3.5, 2.2.2, 1.3.6)
> > actionpack (2.3.8, 2.3.5, 2.2.2, 1.13.6)
> > actionwebservice (1.2.6)
> > activerecord (2.3.8, 2.3.5, 2.2.2, 1.15.6)
> > activeresource (2.3.8, 2.3.5, 2.2.2)
> > activesupport (2.3.8, 2.3.5, 2.2.2, 1.4.4)
> > acts_as_ferret (0.4.8, 0.4.3)
> > BlueCloth (1.0.1)
> > capistrano (2.5.19, 2.5.2)
> > cgi_multipart_eof_fix (2.5.0)
> > daemons (1.1.0, 1.0.10)
> > dnssd (1.3.1, 0.6.0)
> > extlib (0.9.15)
> > fastthread (1.0.7, 1.0.1)
> > fcgi (0.8.8, 0.8.7)
> > ferret (0.11.6)
> > gem_plugin (0.2.3)
> > gli (1.1.1)
> > glyph (0.3.0)
> > highline (1.6.1, 1.5.0)
> > hpricot (0.8.2, 0.6.164)
> > libxml-ruby (1.1.4, 1.1.2)
> > mongrel (1.1.5)
> > needle (1.3.0)
> > net-scp (1.0.2, 1.0.1)
> > net-sftp (2.0.4, 2.0.1, 1.1.1)
> > net-ssh (2.0.23, 2.0.4, 1.1.4)
> > net-ssh-gateway (1.0.1, 1.0.0)
> > rack (1.1.0, 1.0.1)
> > rails (2.3.8, 2.3.5, 2.2.2, 1.2.6)
> > rake (0.8.7, 0.8.3)
> > RedCloth (4.2.2, 4.1.1)
> > ruby-openid (2.1.8, 2.1.2)
> > ruby-yadis (0.3.4)
> > rubygems-update (1.3.7)
> > rubynode (0.1.5)
> > sqlite3-ruby (1.3.1, 1.2.4)
> > termios (0.9.4)
> > xmpp4r (0.5, 0.4)
>
> > Is there anything else I need to check?
>
> > Regards,
>
> > Carl