Google Groups

Re: Django-CMS 500 error when clicking to add a plugin


Jonas Obrist Oct 28, 2010 6:26 AM
Posted in group: django CMS users
On 10/28/2010 03:09 PM, allistera wrote:
> Hey I posted this on stackoverflow but have received no replies there.
> I also done a quick search on the group and even tho there are people
> with the same problem, but no solution.
>
> When clicking to add a new plugin ("Add Plugin" on a "Page" I get a
> 500 error. Using firebug I got this traceback:
> Environment:
>
> Request Method: POST
> Request URL: http://192.168.1.10:81/admin/cms/page/1/add-plugin/
> Django Version: 1.2.3
> Python Version: 2.6.6
> Installed Applications:
> ['django.contrib.auth',
>   'django.contrib.contenttypes',
>   'django.contrib.sessions',
>   'django.contrib.sites',
>   'django.contrib.messages',
>   'django.contrib.admin',
>   'cms',
>   'cms.plugins.text',
>   'cms.plugins.picture',
>   'cms.plugins.link',
>   'cms.plugins.file',
>   'cms.plugins.snippet',
>   'cms.plugins.googlemap',
>   'mptt',
>   'publisher']
> Installed Middleware:
> ('django.middleware.common.CommonMiddleware',
>   'django.contrib.sessions.middleware.SessionMiddleware',
>   'django.middleware.csrf.CsrfViewMiddleware',
>   'django.contrib.auth.middleware.AuthenticationMiddleware',
>   'django.contrib.messages.middleware.MessageMiddleware',
>   'cms.middleware.page.CurrentPageMiddleware',
>   'cms.middleware.user.CurrentUserMiddleware',
>   'cms.middleware.media.PlaceholderMediaMiddleware')
>
>
> Traceback:
> File "/usr/local/lib/python2.6/dist-packages/django/core/handlers/
> base.py" in get_response
>    100.                     response = callback(request,
> *callback_args, **callback_kwargs)
> File "/usr/local/lib/python2.6/dist-packages/django/utils/
> decorators.py" in _wrapped_view
>    76.                     response = view_func(request, *args,
> **kwargs)
> File "/usr/local/lib/python2.6/dist-packages/django/views/decorators/
> cache.py" in _wrapped_view_func
>    69.         response = view_func(request, *args, **kwargs)
> File "/usr/local/lib/python2.6/dist-packages/django/contrib/admin/
> sites.py" in inner
>    190.             return view(request, *args, **kwargs)
> File "/usr/local/lib/python2.6/dist-packages/django_cms-2.1.0.beta3-
> py2.6.egg/cms/admin/pageadmin.py" in add_plugin
>    1061.                 placeholder = get_object_or_404(Placeholder,
> pk=placeholder_id)
> File "/usr/local/lib/python2.6/dist-packages/django/shortcuts/
> __init__.py" in get_object_or_404
>    88.         return queryset.get(*args, **kwargs)
> File "/usr/local/lib/python2.6/dist-packages/django/db/models/
> query.py" in get
>    333.         clone = self.filter(*args, **kwargs)
> File "/usr/local/lib/python2.6/dist-packages/django/db/models/
> query.py" in filter
>    550.         return self._filter_or_exclude(False, *args, **kwargs)
> File "/usr/local/lib/python2.6/dist-packages/django/db/models/
> query.py" in _filter_or_exclude
>    568.             clone.query.add_q(Q(*args, **kwargs))
> File "/usr/local/lib/python2.6/dist-packages/django/db/models/sql/
> query.py" in add_q
>    1128.                             can_reuse=used_aliases)
> File "/usr/local/lib/python2.6/dist-packages/django/db/models/sql/
> query.py" in add_filter
>    1071.                 connector)
> File "/usr/local/lib/python2.6/dist-packages/django/db/models/sql/
> where.py" in add
>    66.             value = obj.prepare(lookup_type, value)
> File "/usr/local/lib/python2.6/dist-packages/django/db/models/sql/
> where.py" in prepare
>    299.             return self.field.get_prep_lookup(lookup_type,
> value)
> File "/usr/local/lib/python2.6/dist-packages/django/db/models/fields/
> __init__.py" in get_prep_lookup
>    292.             return self.get_prep_value(value)
> File "/usr/local/lib/python2.6/dist-packages/django/db/models/fields/
> __init__.py" in get_prep_value
>    479.         return int(value)
>
> Exception Type: ValueError at /admin/cms/page/1/add-plugin/
> Exception Value: invalid literal for int() with base 10: 'body'
>
>
> This is an default simple install of django-cms, all latest versions,
> and through python 2.6.
>
What exact veresion of the cms?