Google Groups

RE: [beagleboard] gcc & g++


John (USP) May 16, 2012 11:13 AM
Posted in group: BeagleBoard

Categories: Software : Angstrom : Hardware :

 

From: beagl...@googlegroups.com [mailto:beagl...@googlegroups.com] On Behalf Of rahim panahi
Sent: Wednesday, May 16, 2012 2:58 AM
To: beagl...@googlegroups.com
Subject: [beagleboard] gcc & g++

 

Hi all
I've downloaded a toolchain containing gcc and g++ in it , after installing angstrom from narcissus I've tried to compile the toolchain so
as I've read from somepages in internet I went to this folder
/usr/local/angstrom/arm    and entered the following command
sh ./environment-setup
but nothing happend and just the command line jumped to another line as below :

>>root@beagleboard:/usr/local/angstrom/arm#  sh ./environment-setup
>>root@beagleboard:/usr/local/angstrom/arm#
 
and I thought that gcc and g++ were installed by this command so I ran this code to compile my opencv example to see if I can see a simple image
histogram or not
>>root@beagleboard:/# g++ -o Hist Hist.cpp `pkg-config --libs opencv` `pkg-config --cflags opencv`
but the output was :
>> sh: g++: not found
 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

The arm cross compiler command would be arm-angstrom-linux-gnueabi-g++ or arm-angstrom-linux-gnueabi-gcc

 

Regards,

John


I'm sure that my toolchain contains gcc and g++ because I searched the arm folder and found them , but I think that  they are not installed .
any suggestion about this problem(my compile command is wrong or ...) ?

-- To join: http://beagleboard.org/discuss
To unsubscribe from this group, send email to:
beagleboard...@googlegroups.com
Frequently asked questions: http://beagleboard.org/faq