Google Groups

Re: Slack 14.0 CD won't load!

Michael Black Jul 20, 2013 11:00 AM
Posted in group: alt.os.linux.slackware
On Sat, 20 Jul 2013, joop g wrote:

> notbob wrote:
>> On 2013-07-20, joop g <> wrote:
>>>> Other CDs load without problems
>>> Sorry, I should have said "DVD".
>> Does that apply to "other CDs" also?
>> May jes be faulty hardware.  I know my ancient Vaio P4 box will not boot
>> from its DVD, despite it having a DVD player and a bios that indicates
>> the DVD drive is bootable.  I hadda burn a full set of CDs to install
>> 13.37.  Try some other bootable DVD.
>> nb
> Well, an update: today I tried the old 12.1 DVD, from which I installed the
> system a few years ago. Didn't load. I am pretty sure that it loaded years
> ago...
> Well, the system has to be up and running before Monday, so I tried a Debian
> CD (yes, it was a CD, using Netinstall). No problems (well, actually, there
> was some fuss about missing firmware, but I could find that via google). So
> I think I will have to go for Debian, at least for this system.
> Well, this happened to be a real CD, but I don't think that is the issue.I
> also tried an Ubuntu server DVD, but I decided not to go ahead when it
> threatened to format my whole disk (including about 1 TByte of data which I
> want to keep). But it definitely loaded and ran. Everything does, except
> Slackware :-(
Henrik mentions the "-boot-load-size 32".

I think even on my 2003 1GHz computer, I had to use the smartbootmanager
program (I forget the exact name but it used to be on the SLackware
release, somewhere) to boot from the CD or DVD.  Put the bootmanager on
a floppy disk, and then boot from the floppy disk, which in turn allowed
one to boot from the DVD.

This was an issue, and for a long time Slackware used some old standard so
old hardware could boot the disk.  Then eventually that was changed (I
forget at which release) so we had to boot other ways with old hardware,
or get new hardware.

This is hazy because I can't fully remember, but I'm pretty sure I had to
use the smart boot manager until I moved to this 3GHz computer last

It has something to do with the BIOS not being able to read larger boot
images or something, it was discussed on the changelog at one point, was
discussed here, but years back so I can't remember details.

You could move the needed things to a USB flash drive, boot from that
(assuming your computer can boot from USB) then once the installer gets
going, point it to the pacakges on the DVD, and that should work.