Google Groups

Using latest support library w/ maven.


Mark Andrachek, Jr. Sep 28, 2012 2:16 PM
Posted in group: ActionBarSherlock
In my eclipse projects, I've been able to add the ABS library project, and replace the support library jar file without problems, allowing me to use the latest version.  Anyone know if I'll hit problems with a configuration like this with maven? It seems to be working at the moment...

   <dependencies>
        <dependency>
            <groupId>android</groupId>
            <artifactId>android</artifactId>
            <version>4.1_r2</version>
            <scope>provided</scope>
        </dependency>
        <dependency>
          <groupId>android.support</groupId>
          <artifactId>compatibility-v4</artifactId>
          <version>r10</version>
        </dependency>
        <dependency>
          <groupId>com.actionbarsherlock</groupId>
          <artifactId>library</artifactId>
          <version>4.1.0</version>
          <type>apklib</type>
          <exclusions>
              <exclusion>
                <groupId>com.google.android</groupId>
                <artifactId>support-v4</artifactId>
              </exclusion>
            </exclusions>
        </dependency>
    </dependencies>