[patch] 'guicolors' option name does not intuitive.

177 views
Skip to first unread message

h_east

unread,
Apr 24, 2016, 2:50:51 PM4/24/16
to vim_dev
Hi Bram and list.

I think that 'guicolors' option name does not intuitive.
This option for terminal, but prefix is 'gui'
I think it's unnatural.

I propose to rename option name to 'termtruecolor'. (Short name is 'ttc')
How about this?

NOTE:
This has been first proposed by Ken Takada.

Patch attached.
Please check this.
--
Best regards,
Hirohito Higashi (a.k.a. h_east)

rename_opt_guicolors_to_termtruecolor.patch

Christian J. Robinson

unread,
Apr 24, 2016, 2:54:16 PM4/24/16
to vim_dev
On Sun, 24 Apr 2016, h_east wrote:

> I think that 'guicolors' option name does not intuitive.
> This option for terminal, but prefix is 'gui'
> I think it's unnatural.

I understand the logic behind the current naming, but I still agree
that it's confusing.

> I propose to rename option name to 'termtruecolor'.

I support this.

- Christian

--
Due to inflation, all clouds will now be lined with zinc.
Christian J. Robinson <hep...@gmail.com> http://christianrobinson.name/

Nikolay Aleksandrovich Pavlov

unread,
Apr 24, 2016, 3:05:31 PM4/24/16
to vim_dev
2016-04-24 21:54 GMT+03:00 Christian J. Robinson <hep...@gmail.com>:
> On Sun, 24 Apr 2016, h_east wrote:
>
>> I think that 'guicolors' option name does not intuitive.
>> This option for terminal, but prefix is 'gui'
>> I think it's unnatural.
>
>
> I understand the logic behind the current naming, but I still agree that
> it's confusing.

I would suggest &termguicolors (&tgc) then. The main reasoning is that
option name should point that guifg/guibg attributes will be used,
&termtruecolor name does not point to this fact.

Bram Moolenaar

unread,
Apr 24, 2016, 4:03:24 PM4/24/16
to h_east, vim_dev

Hirohito Higashi wrote:

> I think that 'guicolors' option name does not intuitive.
> This option for terminal, but prefix is 'gui'
> I think it's unnatural.
>
> I propose to rename option name to 'termtruecolor'. (Short name is 'ttc')
> How about this?
>
> NOTE:
> This has been first proposed by Ken Takada.
>
> Patch attached.
> Please check this.

Yes, I was wondering what users think of when seeing 'guicolors'. The
main thing it does is using the GUI colors for the terminal. Whether
it's actually true colors depends on the terminal.

So, how about 'termguicolors'?

Ah, I see Nikolai also suggested this.

--
There can't be a crisis today, my schedule is already full.

/// Bram Moolenaar -- Br...@Moolenaar.net -- http://www.Moolenaar.net \\\
/// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
\\\ an exciting new programming language -- http://www.Zimbu.org ///
\\\ help me help AIDS victims -- http://ICCF-Holland.org ///

Dominique Pellé

unread,
Apr 24, 2016, 4:18:32 PM4/24/16
to vim_dev
Bram Moolenaar <Br...@moolenaar.net> wrote:

> Hirohito Higashi wrote:
>
>> I think that 'guicolors' option name does not intuitive.
>> This option for terminal, but prefix is 'gui'
>> I think it's unnatural.
>>
>> I propose to rename option name to 'termtruecolor'. (Short name is 'ttc')
>> How about this?
>>
>> NOTE:
>> This has been first proposed by Ken Takada.
>>
>> Patch attached.
>> Please check this.
>
> Yes, I was wondering what users think of when seeing 'guicolors'. The
> main thing it does is using the GUI colors for the terminal. Whether
> it's actually true colors depends on the terminal.
>
> So, how about 'termguicolors'?
>
> Ah, I see Nikolai also suggested this.

'termguicolors' sounds good to me. But how about giving it
a value instead of being a boolean? So we can later
implement different values such as:

- 1 for true colors terminal i.e. 16 million colors
- 2 for 256 color terminal
- 3 for 88 color terminal

Dominique

Nikolay Aleksandrovich Pavlov

unread,
Apr 24, 2016, 4:29:54 PM4/24/16
to vim_dev
I do not like options which use magic numbers. If this is enum option,
it should be string option and not number (since VimL does not have
enum type).

Also why do you think that moving CSApprox into core is a good idea?
There are other ways to make it faster.

>
> Dominique
>
> --
> --
> You received this message from the "vim_dev" maillist.
> Do not top-post! Type your reply below the text you are replying to.
> For more information, visit http://www.vim.org/maillist.php
>
> ---
> You received this message because you are subscribed to the Google Groups "vim_dev" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+u...@googlegroups.com.
> For more options, visit https://groups.google.com/d/optout.

h_east

unread,
Apr 24, 2016, 5:51:36 PM4/24/16
to vim_dev, h.eas...@gmail.com
Hi Bram and List!

2016-4-25(Mon) 5:03:24 UTC+9 Bram Moolenaar:


> Hirohito Higashi wrote:
>
> > I think that 'guicolors' option name does not intuitive.
> > This option for terminal, but prefix is 'gui'
> > I think it's unnatural.
> >
> > I propose to rename option name to 'termtruecolor'. (Short name is 'ttc')
> > How about this?
> >
> > NOTE:
> > This has been first proposed by Ken Takada.
> >
> > Patch attached.
> > Please check this.
>
> Yes, I was wondering what users think of when seeing 'guicolors'. The
> main thing it does is using the GUI colors for the terminal. Whether
> it's actually true colors depends on the terminal.
>
> So, how about 'termguicolors'?
>
> Ah, I see Nikolai also suggested this.

Yes, patch update.

guicolors --> termguicolors
gcol --> tgc
termtruecolor --> termguicolors
FEAT_TERMTRUECOLOR --> FEAT_TERMGUICOLORS


> > NOTE:
> > This has been first proposed by Ken Takada.

Sorry, It was a mistake.
He is Ken Takata.

Thanks.

rename_opt_guicolors_to_termguicolors_2.patch

Ken Takata

unread,
Apr 25, 2016, 5:58:05 AM4/25/16
to vim_dev, h.eas...@gmail.com
Hi h_east,

2016/4/25 Mon 6:51:36 UTC+9 h_east wrote:
> Hi Bram and List!
>
> 2016-4-25(Mon) 5:03:24 UTC+9 Bram Moolenaar:
> > Hirohito Higashi wrote:
> >
> > > I think that 'guicolors' option name does not intuitive.
> > > This option for terminal, but prefix is 'gui'
> > > I think it's unnatural.
> > >
> > > I propose to rename option name to 'termtruecolor'. (Short name is 'ttc')
> > > How about this?
> > >
> > > NOTE:
> > > This has been first proposed by Ken Takada.
> > >
> > > Patch attached.
> > > Please check this.
> >
> > Yes, I was wondering what users think of when seeing 'guicolors'. The
> > main thing it does is using the GUI colors for the terminal. Whether
> > it's actually true colors depends on the terminal.
> >
> > So, how about 'termguicolors'?
> >
> > Ah, I see Nikolai also suggested this.
>
> Yes, patch update.
>
> guicolors --> termguicolors
> gcol --> tgc
> termtruecolor --> termguicolors
> FEAT_TERMTRUECOLOR --> FEAT_TERMGUICOLORS

I think it's also better to change function names.

Regards,
Ken Takata

termgui_functions.patch

h_east

unread,
Apr 25, 2016, 6:04:59 AM4/25/16
to vim_dev, h.eas...@gmail.com
Hi Ken!

2016-4-25(Mon) 18:58:05 UTC+9 Ken Takata:

Nice catch! Thanks.

Amadeus Demarzi

unread,
Apr 25, 2016, 4:10:48 PM4/25/16
to vim_dev, h.eas...@gmail.com
I've also noticed that if I do

:help guicolors

or

:help 'guicolors'

I get E149: Sorry no help for guicolors

h_east

unread,
Apr 25, 2016, 8:49:19 PM4/25/16
to vim_dev, h.eas...@gmail.com
Hi Amadeus,

2016-4-26(Tue) 5:10:48 UTC+9 Amadeus Demarzi:


> I've also noticed that if I do
>
> :help guicolors
>
> or
>
> :help 'guicolors'
>
> I get E149: Sorry no help for guicolors

If you are using Vim 7.4.1770 previously, should be updated to the new version.
If not, run the following command in Vim.

:helptags ALL

Thanks

h_east

unread,
Apr 25, 2016, 8:57:40 PM4/25/16
to vim_dev, h.eas...@gmail.com
Hi

2016-4-26(Tue) 9:49:19 UTC+9 h_east:


> Hi Amadeus,
>
> 2016-4-26(Tue) 5:10:48 UTC+9 Amadeus Demarzi:
> > I've also noticed that if I do
> >
> > :help guicolors
> >
> > or
> >
> > :help 'guicolors'
> >
> > I get E149: Sorry no help for guicolors
>
> If you are using Vim 7.4.1770 previously, should be updated to the new version.
> If not, run the following command in Vim.
>
> :helptags ALL

Vim 7.4.1784 or later is recommended.

h_east

unread,
Apr 27, 2016, 2:57:38 AM4/27/16
to vim_dev, h.eas...@gmail.com
Hi Bram, Ken and list,

2016-4-25(Mon) 19:04:59 UTC+9 h_east:

I update a patch.
- Ready for 7.4.1795
- Merge Ken's patch
https://groups.google.com/d/msg/vim_dev/q2LuLFueRbE/b848hy1jAgAJ

Please check this.

rename_opt_guicolors_to_termguicolors_3.patch

h_east

unread,
Apr 28, 2016, 4:00:48 AM4/28/16
to vim_dev, h.eas...@gmail.com
Hi Bram and list,

2016-4-27(Wed) 15:57:38 UTC+9 h_east:

Patch update.
Now ready to apply the patch to Vim 7.4.1796. :-)

rename_opt_guicolors_to_termguicolors_4.patch

Bram Moolenaar

unread,
Apr 28, 2016, 5:19:22 AM4/28/16
to h_east, vim_dev
Thanks! I'll include it soon (but I'm quite busy...).

--
A hamburger walks into a bar, and the bartender says: "I'm sorry,
but we don't serve food here."
Reply all
Reply to author
Forward
0 new messages