[siemens/jailhouse] 8d9caf: arm: Avoid assignment in if clause

2 views
Skip to first unread message

GitHub

unread,
Sep 25, 2016, 10:37:29 AM9/25/16
to jailho...@googlegroups.com
Branch: refs/heads/next
Home: https://github.com/siemens/jailhouse
Commit: 8d9caf596ab4d640fa272cb4c33b50e1df16c211
https://github.com/siemens/jailhouse/commit/8d9caf596ab4d640fa272cb4c33b50e1df16c211
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/arch/arm/irqchip.c

Log Message:
-----------
arm: Avoid assignment in if clause

Better readability, less risk to confuse with comparisons.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: 4b27cac4c910f2dfba0041b5fdf962766fa57d9f
https://github.com/siemens/jailhouse/commit/4b27cac4c910f2dfba0041b5fdf962766fa57d9f
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/arch/arm/irqchip.c

Log Message:
-----------
arm: Assume irqchip init function is available

Having no init function for the irqchip is a programming error, not a
runtime issue.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: e9466d272e6f9ea5cd1ef5411804ff2d09b4afd4
https://github.com/siemens/jailhouse/commit/e9466d272e6f9ea5cd1ef5411804ff2d09b4afd4
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/arch/arm/irqchip.c

Log Message:
-----------
arm: Rework no-GICD-case in irqchip_init

If we fail here, the hypervisor cannot be initialized. So there is no
point in (partial) rollback. Furthermore, replace the explicit error
message with proper trace_error.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: a5d1415f3cb2706731eb28b26e5e4f835ed87858
https://github.com/siemens/jailhouse/commit/a5d1415f3cb2706731eb28b26e5e4f835ed87858
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M ci/jailhouse-config-banana-pi.h
M ci/jailhouse-config-vexpress.h
M hypervisor/arch/arm/Makefile
M inmates/lib/arm/Makefile

Log Message:
-----------
arm: Rename CONFIG_ARM_GIC to CONFIG_ARM_GIC_V2

Makes it clearer what this is selecting.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: bfa8093154021c9cc4970b20baf0da7b6e425a95
https://github.com/siemens/jailhouse/commit/bfa8093154021c9cc4970b20baf0da7b6e425a95
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M ci/jailhouse-config-vexpress.h

Log Message:
-----------
ci: Build vexpress with GICv3

Ensures that we build-test the GICv3 code as well.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: e9c38ea5eee50189f292fdf56825a2a7ecb5635d
https://github.com/siemens/jailhouse/commit/e9c38ea5eee50189f292fdf56825a2a7ecb5635d
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/arch/arm/gic-common.c
M hypervisor/arch/arm/gic-v2.c
M hypervisor/arch/arm/gic-v3.c
A hypervisor/arch/arm/include/asm/gic.h
R hypervisor/arch/arm/include/asm/gic_common.h
M hypervisor/arch/arm/irqchip.c
M hypervisor/arch/arm/traps.c

Log Message:
-----------
arm: Rename gic_common.h to gic.h

gic.h is already the only interface header for the GIC, so there is no
reason to add a suffix to it.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: eb06f3326053da7469cb6369e54b8029c558e782
https://github.com/siemens/jailhouse/commit/eb06f3326053da7469cb6369e54b8029c558e782
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/arch/arm/include/asm/gic.h
M hypervisor/arch/arm/include/asm/platform.h

Log Message:
-----------
arm: Include gic_v2/3.h from gic.h

Moving this include away from the platform.h prepares for getting rid of
latter.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: 28d74817b7f69711a3d2453d2d625bbb5e928c82
https://github.com/siemens/jailhouse/commit/28d74817b7f69711a3d2453d2d625bbb5e928c82
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/arch/arm/include/asm/platform.h
M hypervisor/arch/arm/smp-vexpress.c

Log Message:
-----------
arm: Move SYSREGS_BASE into smp-vexpress module

It's a natural constant on this platform, and only there.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: c34d95be2f17760ae78021b6c138fbe84d5bd242
https://github.com/siemens/jailhouse/commit/c34d95be2f17760ae78021b6c138fbe84d5bd242
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/arch/arm/include/asm/gic_v2.h
M hypervisor/arch/arm/include/asm/gic_v3.h
M hypervisor/arch/arm/include/asm/platform.h

Log Message:
-----------
arm: Move GIC size constants gic_v2/3.h

These region mapping sizes are dictated by the spec rather than the
platform. GICV_SIZE was unused (it's always identical to GICC_SIZE).

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: 3979964a25cef012a7dbe0dfad86370629b2eba4
https://github.com/siemens/jailhouse/commit/3979964a25cef012a7dbe0dfad86370629b2eba4
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/arch/arm/gic-common.c
M hypervisor/arch/arm/gic-v2.c
M hypervisor/arch/arm/gic-v3.c
M hypervisor/arch/arm/irqchip.c

Log Message:
-----------
arm: Remove gic*_size variables

They are true constants.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: 0548aea73d9579fbf81d3f875185fcb98441e31c
https://github.com/siemens/jailhouse/commit/0548aea73d9579fbf81d3f875185fcb98441e31c
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M configs/bananapi.c
M configs/jetson-tk1.c
M configs/vexpress.c
M hypervisor/arch/arm/control.c
M hypervisor/arch/arm/dbg-write.c
M hypervisor/arch/arm/gic-common.c
M hypervisor/arch/arm/gic-v2.c
M hypervisor/arch/arm/gic-v3.c
R hypervisor/arch/arm/include/asm/platform.h
M hypervisor/arch/arm/irqchip.c
M hypervisor/arch/arm/traps.c
M hypervisor/include/jailhouse/cell-config.h

Log Message:
-----------
arm: Move content of platform.h into system configuration

Overcome the constantly growing ugly platform.h by defining
platform_info.arm in the system configuration. We need the base
addresses of GICD/C/H/V/R here and the maintenance interrupt number. No
need to account for the fact that only GICv3 needs GICR and not C/H/V -
makes the definition more compact, and we have enough space.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: c66c08946233849ae1a4e01dd0b6e5b4ee24f5b3
https://github.com/siemens/jailhouse/commit/c66c08946233849ae1a4e01dd0b6e5b4ee24f5b3
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/arch/arm/gic-common.c
M hypervisor/arch/arm/gic-v2.c
M hypervisor/arch/arm/gic-v3.c
M hypervisor/arch/arm/include/asm/gic.h

Log Message:
-----------
arm: Move gicd_base declarations into header

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: 96ceb1645b85aa968bcb6610fe4ca9d9444618fa
https://github.com/siemens/jailhouse/commit/96ceb1645b85aa968bcb6610fe4ca9d9444618fa
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/include/jailhouse/paging.h
M hypervisor/paging.c

Log Message:
-----------
core: Introduce paging_map/unmap_device

These services are wrapping the common pattern of page allocation from
the remapping pool and then mapping of a physical device into the
hypervisor address space / the reverse of it. They will also replace the
ARM-specific Implementations.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: d009abf1cb2b7ef01d204f402027ea8890489a82
https://github.com/siemens/jailhouse/commit/d009abf1cb2b7ef01d204f402027ea8890489a82
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/pci.c

Log Message:
-----------
core: Use paging_map/unmap_device in PCI layer

Less boilerplate code.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: e20105e7423d85bc239bb30030c72627b6104dba
https://github.com/siemens/jailhouse/commit/e20105e7423d85bc239bb30030c72627b6104dba
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/arch/x86/amd_iommu.c
M hypervisor/arch/x86/apic.c
M hypervisor/arch/x86/ioapic.c

Log Message:
-----------
x86: Use paging_map/unmap_device for AMD IOMMU, APIC and IOAPIC

We cannot use the functions for svm because it reuses the virtual
address for the AVIC page on all CPUs. And vtd maps all DMAR units
back-to-back, even when their physical addresses are scattered.

Still quite some boilerplate code removed.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: 6d83e228254270c6155a411713526c115ccd21b2
https://github.com/siemens/jailhouse/commit/6d83e228254270c6155a411713526c115ccd21b2
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/arch/arm/gic-v2.c
M hypervisor/arch/arm/gic-v3.c
M hypervisor/arch/arm/irqchip.c
M hypervisor/arch/arm/smp-vexpress.c

Log Message:
-----------
arm: Use paging_map/unmap_device for GIC and vexpress sysregs

Less boilerplate code, arch_map/unmap_device becomes unused, and we also
properly allocate the virtual addresses of the mapped resources from the
remapping pool, instead of relying on identity mapping creating no
conflicts.

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Commit: 5a2a131566ac13271c2a90ef6d2fb54cf02f732c
https://github.com/siemens/jailhouse/commit/5a2a131566ac13271c2a90ef6d2fb54cf02f732c
Author: Jan Kiszka <jan.k...@siemens.com>
Date: 2016-09-25 (Sun, 25 Sep 2016)

Changed paths:
M hypervisor/arch/arm/include/asm/setup.h
M hypervisor/arch/arm/mmu_hyp.c

Log Message:
-----------
arm: Remove unused arch_map/unmap_device

Signed-off-by: Jan Kiszka <jan.k...@siemens.com>


Compare: https://github.com/siemens/jailhouse/compare/b267f36bfd95...5a2a131566ac
Reply all
Reply to author
Forward
0 new messages