I've looked at the patch and it seems good to me.
I have a suggestion:
Rather than (receiver, err, traceback), why not (receiver, exc_info)
where exc_info is the triple returned by sys.exc_info()? There's no
harm in changing the meaning of the 2nd tuple element if people are
opting into the change.
Similarly, rather than append_traceback, why not call it
exc_info=True? This parallels the logging module's use of the kwarg:
http://docs.python.org/library/logging.html#logging.Logger.debug
Well, I meant to mark accepted as endorsement of the patch, but that
made me owner.
I can't own it since I'm not a core committer.
Setting it back to nobody set the status to "new".
Hopefully a core will agree this is a good approach.
Hopefully a core will agree this is a good approach.