Checkstyle 6.14

1 view
Skip to first unread message

Roman Ivanov

unread,
Dec 28, 2015, 11:09:04 AM12/28/15
to checkstyle-announce

Breaking backward compatibility:

  Remove parameters validation from LocalVariableName.

New:

  Print name of the Check after printing violation message.
  WhitespaceAround should have an allowEmptyLambda parameter.
  Add ENUM_CONSTANT_DEF support to MethodParamPad .
  new CatchParameterName Check: to validate names of catch-block parameters only.

Bug fixes:

  FinalLocalVariable false-positive in SWITCH.
  Typo in Javadoc tag name.
  Extend parsing rule of custom Javadoc tag name.
  Nesting Checks in each other in config does not produce any error.
  RequireThis check message is not clear enough.
  OneStatementPerLine: false match with try-with-resources.
  Performance issue in UnusedImportsCheck.
  Remove unused message.
  Create directory structure needed to store cache file.
  AbbreviationAsWordInName incorrectly reports constants in annotations.
  Inconsistent violations for NeedBraces/allowSingleLineStatement.
  ParameterNameCheck: NullPointerException over checkstyle's input file.
  @SuppressWarnings annotation does not suppress UncommentedMain.
  UncommentedMain does not rise violations if main method has varargs as parameters.
  Fix 'tokens' property in JavadocStyle check.
  GenericWhitespace: violation on generic like '...... instanceof Type<?>;'.
  AbbreviationAsWordInName: update message to print name that violates a format.

Notes:

  Use Nexus Staging Maven Plugin for release process.
  Enforce Checks of sevntu.checkstyle (released version) over Checkstyle source code.
  Make UT 'testNonAccessibleFile' locale independent .
  Refactor gui package.
  Make DetectorOptions as final and immutable.
  Fix additional issues reported by IntelliJ IDEA inspections in Checkstyle code.
  conf: update guava version to 19.0.
  doc: Correct regexp in configuration example for ParameterNameCheck.
  doc: Add example for ParameterName into xdoc.
  doc: Fix check name in CatchParameterName xdoc.
  doc: Update comment in google_checks.xml.
  Reorganize token sets in UncommentedMain.
  refactor internal tests.
  Update configuration for XXXXName Checks at checkstyle_checks.xml.
  Make validation of expected warnings in integration tests more strict.
  spelling: fix typo in word 'Existing' in google_style.xml.
  Fix ParseTreeBuilder's variable names to be more readable.

Reply all
Reply to author
Forward
0 new messages