Hi Eran,
Yes, in order to only enable a few rules to the group of agents specified in the sample rule shown above you may add them as children rules.
So for example you may copy a few rules from the default ruleset to be considered for this group of agents:
<rule id="105100" level="0" noalert="1">
<if_sid>100002</if_sid>
<decoded_as>dropbear</decoded_as>
<description>Grouping for dropbear rules.</description>
</rule>
<rule id="105103" level="5">
<if_sid>105100</if_sid>
<match>bad password attempt for</match>
<description>Dropbear: Bad password attempt.</description>
<group>authentication_failed,pci_dss_10.2.4,pci_dss_10.2.5,pci_dss_8.1.5,gpg13_7.1,gdpr_IV_35.7.d,gdpr_IV_32.2,hipaa_164.312.b,hipaa_164.312.a.1,nist_800_53_AU.14,nist_800_53_AC.7,nist_800_53_AC.2,tsc_CC6.1,tsc_CC6.8,tsc_CC7.2,tsc_CC7.3,</group>
</rule>
</group>
Note how all of the new rules must have a unique ID (and it is best practices to keep the IDs of custom rules between 100001 and 119999.
Let us know if there is anything else we can help with.