Invalid Topology Error

Skip to first unread message

Devany Bosetti

May 31, 2022, 9:30:57 PM5/31/22
to ACPF Forum
Hello everyone,

I am usually able to troubleshoot my way out of most issues, but have something I'm really spinning my wheels with and hoping someone might have seen/dealt with it before. 

I have a watershed I am working on and managed to make it through to creating the riparian attributes polygons, but I keep getting an invalid topology error (first and only time I have ever gotten this error) and I am at a loss as to how to fix it. I have tried repairing geometry (as suggested by google) but it hasn't helped. I also went back and started my stream reach from scratch using both PD and AF in hopes that something just went wrong along the way and I still get this error when I get to this step. 

I have a feeling it might have to do with a single lone catchment that really shouldn't be included, but when I run the stream reach and catchments tool, it continues to be included. I have tried to ensure that my stream network ends at the pour point to ensure that there isn't contributing flow causing it to create a catchment there, but each time I have tried this catchment continues to be included (two creeks feed into this watershed, and this one extra catchment really should be two catchments split up between two other watersheds). Am I missing something silly here?



David James

Jun 1, 2022, 9:36:31 AM6/1/22
to Devany Bosetti, ACPF Forum
This is an interesting error. If you have confidence in the stream reach feature class and the Create Riparian Buffers is successful, then it may be something else. 

Regards the spurious catchment created downstream of the pourpoint, these are not uncommon and can be deleted. They result from having elevation data beyond the watershed boundary and the StreamReach & Catchments tool trying to account for all flow. In many cases there may also be an associated spurious stream segment that is generated, especially if you use the PD method of flow modeling. In these cases both the spurious stream segments and catchments can be deleted. It is unlikely that this one catchment is causing your problem, but delete and try again.

I think the problem may have to do with your stream network and the riparian buffers. I would look at the stream reach fc and see if there any missing segments...those that may have been missed when assigning values to the stream type field of the PD or AreaThreshold network. The USLINKNO(1 | 2) may help, look at those with a -1 value, they are headwaters or stream initiation segments. Are there any out of place? Also examine any 0-length stream reach segments.

It may be helpful to look for riparian catchments that are very small. These may point to issues with the stream reach fc as well.

If you continue to have issues, let me know and we can pursue other avenues.

Dave James

The ACPF Forum is an online group for discussing technical issues related to using the ACPF tools. Anyone can view the discussions at Only members can participate in discussions. Join the group by sending an email to
You received this message because you are subscribed to the Google Groups "ACPF Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To view this discussion on the web visit

Devany Bosetti

Jun 1, 2022, 11:38:10 AM6/1/22
to ACPF Forum,, ACPF Forum
Dave, you are legendary, thank you so much for the advice! There was a tiny little 0 length segment that I deleted but it did not address the topology issue (nor did deleting both the tiny 0 length segment and the extra catchment) and ultimately the issue was indeed was a couple misclassified tiny tiny stream segments. After reclassifying them and rerunning, the RAP tool proceeded without error! Thank you so much for taking the time to help with this error!
Reply all
Reply to author
0 new messages