Issue due to Version Conflict

Skip to first unread message

Sarath Marson

Feb 23, 2023, 3:27:30 AM2/23/23
to TensorFlow Hub
My name is Sarath. I am doing a course related to Tensorflow in Linkedin. I recently met with an issue in setting up the model traning loop using tensorflow in pycharmIDE. 

wehn I execute thr training I receive the following error:

AttributeError: module 'tensorflow' has no attribute 'variable_scope'

Process finished with exit code 1

I intalled tensorflow 2  and using Python 3.9.... I think this is beacuse of the version conflict that tensorflow 2 doesnt supports some functions used in Tensorflow 1. When I tried to downgrade my tensorflow version, ir showed the following error message:

ERROR: Could not find a version that satisfies the requirement tensorflow==1.1 (from versions: 2.8.0rc1, 2.8.0, 2.8.1, 2.8.2, 2.8.3, 2.8.4, 2.9.0rc0, 2.9.0rc1, 2.9.0rc2, 2.9.0, 2.9.1, 2.9.2, 2.9.3, 2.10.0rc0, 2.10.0rc1, 2.10.0rc2, 2.10.0rc3, 2.10.0, 2.10.1, 2.11.0rc0, 2.11.0rc1, 2.11.0rc2, 2.11.0, 2.12.0rc0)
ERROR: No matching distribution found for tensorflow==1.1

Is there any way to solve this issue? Any tips is highly appreciated :).

Thanks in Advance
Reply all
Reply to author
0 new messages