Urgent assistance needed with Error with BIRT Templates & profile images

20 views
Skip to first unread message

Debby Thomson - Bushveld Connections

unread,
Aug 29, 2021, 5:35:08 AMAug 29
to SMART Software Google Group

I wonder if anyone can help me work out why the following may have occurred:

 

I have been working with the profiles section of SMART for a while now and it is one of the primary aspects that we rely on.  From the start I set up the BIRT Templates related to each entity type and have been working with these continually each time we print out a report.  Suddenly this morning I am wanting to work on some of the profiles and the following errors are now occurring:

 

Firstly, it is not bringing up previews of any of the attached images related to a profile

And secondly, all my BIRT templates seemed to have disappeared and have all resorted back to the default BIRT.   Obviously at present the entire Profiles section is not functioning which is of MAJOR concern to me as it I the central hub of all our sensitive and core information.

 

I am presuming this may have resulted from corrective steps I had to take last night which I will explain below, however, as these same steps have been taken previously with no errors occurring, I am not sure as to why they may have occurred now.

 

So last night I noticed, that I was unable to sync to the Smart desktop on my windows computer (I work on Mac).   I then did as I normally do, and deleted the CA on the windows computer and instructed the computer to re-download the CA from Connect which normally corrects any conflict between the two.

 

I then received another error with downloading from Connect, which then indicated to me that once again (it has happened before) that a photo has been attached to a profile that SMART does not like the name of.   Our case numbers in SA are written out as CAS 22/08/2021 for example, and often images linked to that case are saved with that format and the “/” forward slashes used, are not liked by SMART in the names.    In my previous experience, and to try and cut a long story short, the only way to correct this was to firstly rename everything on my desktop and of course remove incorrectly named images from the profiles, and to then reattach the newly named images, however, when syncing this still did not seem to work as the incorrect files seemed to remain on the Connect database.    The next step was then to delete the desktop data from Connect and to re-upload the CA to connect.   This was successfully done and everything worked perfectly again thereafter.

 

Yesterday I noticed the same error had occurred and found the image that had been attached to a profile that was saved using the forwarded slashes as before.   As it had all worked so perfectly before, I then re-did the same process – ie deleted the desktop data from Connect and re-uploaded the CA, however, I am not experiencing the problems as per above.

 

Any ideas as to how this may have occurred and is there any solution apart from re-setting up all the BIRT templates and re-building all the profiles from scratch???

 

If anyone can get back to me URGENTLY on this matter would be greatly appreciated

Debby  

Matt Hron

unread,
Aug 30, 2021, 2:49:02 PMAug 30
to Debby Thomson - Bushveld Connections, SMART Software Google Group
Hi Debby,
I'm not familiar with this functionality, but I'll see if I can find an expert to help you. One thing that would help is if you can send the error log so we can see the details of the error you're getting.

Regards,
Matt

--
You received this message because you are subscribed to the Google Groups "SMART Community Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to community+...@smartconservationsoftware.org.
To view this discussion on the web visit https://groups.google.com/a/smartconservationsoftware.org/d/msgid/community/221234F9-5098-4B2C-9244-F2E1A9898CC0%40bushveldconnections.co.za.


--
Matt Hron
Director of Product and Customer Success
Wildlife Protection Solutions
Skype: matthew.hron
 
Reply all
Reply to author
Forward
0 new messages