Where to install annotation tool?

20 views
Skip to first unread message

Sven Laudel

unread,
Jul 5, 2022, 5:20:18 AMJul 5
to Opencast Annotation Tool
Hello all,

I'm playing around with the annotation tool and am trying to install it into our Opencast 11 test cluster.
What I'm missing from the documentation is, on what cluster node do I install annotation tool and where to put which configuration?

Best regards
Sven

King_S

unread,
Jul 5, 2022, 5:35:41 AMJul 5
to annotat...@opencast.org
Hi Sven, 

I installed it on the presentation-node, because this node has the search endpoint. Don't know, if this is correct. 

Regards 

Stephan 

--
To unsubscribe from this group and stop receiving emails from it, send an email to annotation-to...@opencast.org.

Lars Kiesow

unread,
Jul 5, 2022, 7:19:06 AMJul 5
to annotat...@opencast.org
It's a good choice exactly because it uses the search service. That
said, it should also work on admin. But there would be some overhead
since it would then communicate with the service on presentation.
If you don't mind, please extend the documentation!
–Lars

Sven Laudel

unread,
Jul 5, 2022, 9:19:37 AMJul 5
to Opencast Annotation Tool
Thanks Stephan and Lars,

that's what I thought, but wasn't sure about it.
So I compiled annotation tool as described in https://github.com/opencast/annotation-tool/blob/master/documentation/Installation.md and configured etc/org.apache.karaf.features.cfg and security/mh_default_org.xml at our presentation node.
The listproviders and the workflow I configured on the admin node.

This seems to work until I want to access a freshly published event through annotation tool. It starts to load the annotation tool but the it is stuck at "Wird geladen Fenster werden erstellt".
So it seems I missed something.

Best regards
Sven

King_S

unread,
Jul 5, 2022, 12:06:02 PMJul 5
to annotat...@opencast.org
Hi Sven,

As far as I know the etc/org.apache.karaf.features.cfg is with the hot loading not necessary, only the security settings. 

I've added the roles annotation-admin and annotate manually to one published event. 

Did you adjust the listproviders? 

Maybe you should check the webdevoloper output. One of mine errors was a missing setting for the mariaDB in the custom.properties (The MySQL Metadata). 

Regards 

Stephan 
Reply all
Reply to author
Forward
0 new messages