State scripts supported versions

20 views
Skip to first unread message

FAE

unread,
Jan 3, 2019, 11:53:05 AM1/3/19
to Mender List mender.io
Hello,

i've written a test state script, Idle_Enter_10_test but i get an error:

level=error msg=
"statescript: ignoring error while executing [Idle:Enter] script: statescript:
supported versions does not match (supported: [2]; actual: 0)"
module=executor

Does this mean that client and server are not compatible?

Thank you in advance


Adrian Real

unread,
Jan 3, 2019, 12:11:15 PM1/3/19
to Mender List mender.io
I had this problem as well, please see  this thread: https://groups.google.com/a/lists.mender.io/forum/#!topic/mender/QiWYYxrcPOg

FAE

unread,
Jan 4, 2019, 2:57:00 AM1/4/19
to Mender List mender.io
Thank you Adrian

it did work.

Thank you again

Eystein Måløy Stenberg

unread,
Jan 10, 2019, 2:08:43 PM1/10/19
to men...@lists.mender.io, FAE
Thanks, this is clearly confusing and has been discussed several times.

I created this task to improve it, feel free to watch or help improve
this for the future: https://tracker.mender.io/browse/MEN-2318
> --
> You received this message because you are subscribed to the Google
> Groups "Mender List mender.io" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to mender+un...@lists.mender.io
> <mailto:mender+un...@lists.mender.io>.
> To post to this group, send email to men...@lists.mender.io
> <mailto:men...@lists.mender.io>.
> Visit this group at
> https://groups.google.com/a/lists.mender.io/group/mender/.

--

Eystein
Reply all
Reply to author
Forward
0 new messages