ByzPi: How to get services running?

Skip to first unread message

Etienne de L'Amour

Jul 14, 2014, 2:41:17 PM7/14/14
Hi, I'm new to Linux and also to Project Byzantium, so I'm not sure what info to provide or what to look for.

I have ByzPi running in Raspbian on which I'd previously installed Apache2 (listening on 80 but not 443). I can connect from a non-node Windows client. I can join a mesh with another Byzantium node. Apache runs fine. I also have internet access working via eth0.

Clicking on the Avahi start menu entry lists a few items like eth0, wlan0, raspberrypi, but no mention of services like etherpad-lite, (groundstation) or qwebirc.

The non-node client reports (via "No services found in this network."

Running /etc/init.d/webchat-service manually gave: Syntax error. "(" unexpected.
Running /etc/init.d/qwebirc manually gave: Another twistd server is running, PID 2571.

If bootup called /etc/init.d/ssl then it made no attempt to create a server certificate. I ran this manually and it successfully created the key and cert.

On the console at boot up, I spotted:

Setting up resolvconf. Illegal option -- (failed to create runtime directories).
This is followed by a list of other failures for "-e" "-m"; etc.
Startpar: resolvconf failed.

In syslog, the following failed and I saw no mention of starting services:

Jul 14 17:14:13 raspberrypi ifplugd(eth0)[2499]: client: ln: failed to create symbolic link `/etc/resolv.conf': File exists (Points to
Jul 14 17:14:20 raspberrypi ifplugd(eth0)[2499]: Program execution failed, return value is 1.
Jul 14 17:15:40 raspberrypi puppet-agent[2456]: Could not request certificate: getaddrinfo: Name or service not known (Three log entries)

I also noticed that though I can access the Apache web server from another machine, on the RPi I can't browse to localhost/ or

The task manager shows the following running: avahi-daemon, oslrd, puppet, several python.

Hope some of this makes sense to you. Thanks a lot,
Eric T.

Message has been deleted

Etienne de L'Amour

Jul 15, 2014, 9:01:16 AM7/15/14
I noticed in the Apache logs that there was an ovelap in the _default_ SSL virtual hosts (presumably the original Apache httpd-ssl.conf and whatever Byzantium is running), so I left SSL enabled but removed the original /etc/apache2/conf.d/httpd-ssl.conf.

Etienne de L'Amour

Jul 15, 2014, 10:02:12 AM7/15/14
Sorry, I think I got that the wrong way round: Have reinstated /etc/apache2/conf.d/ httpd-ssl.conf (which uses server.crt; etc) and removed the symlink /etc/apache2/sites-enabled/ ssl default (which partially duplicated / overlapped).

Still getting "This mesh network is probably not connected to the internet. No services found in the network. Please try again in a little while."

Etienne de L'Amour

Jul 15, 2014, 3:50:34 PM7/15/14
I think perhaps it would be best if I reinstall a clean copy of Raspbian and then reinstall ByzPi.

Etienne de L'Amour

Jul 16, 2014, 11:39:02 AM7/16/14
No, after a complete re-install of RPi and ByzPi I'm getting the same results.

Etienne de L'Amour

Jul 17, 2014, 6:00:46 AM7/17/14
Looks like the only issue I'm now having is with service discovery.

I was getting a HTTP 500 response and "proxy: no protocol handler was valid for the url". I ran sudo a2enmod proxy_http and that fixed the issue.

ircd *is* running on port 6667; an IRC client is running on port 8989, and I can join IRC. IRC still isn't showing up in services, though, so I temporarily edited /var/www/index.html to include a hardwired link to the IRC client and additional services I want to run on my local node, such as a directory of useful files for download, and dokuwiki.

Great project. Many thanks.

Reply all
Reply to author
0 new messages