vray version issue

29 views
Skip to first unread message

Kang Joo

unread,
Aug 17, 2021, 7:19:29 AMAug 17
to Golaem List
Hello, the vray version I am currently using is v5.10.20. Does Golaem not currently support that version? If you plan to apply later, I wonder when you will apply.

Nicolas Chaverou

unread,
Aug 17, 2021, 7:22:47 AMAug 17
to Golaem List
Hey there,

You can check the Release Notes to see which version of rendering engines is supported by Golaem

Golaem 7.3.11 supports Vray 5 by default
We haven't tried with Vray 5.1 yet but as it's a minor version, it may work straight away. Probably just try rendering and see what happens :)
Let us know how it goes : if it doesn't work, feel free to share render log and we'll check it out

Best,


On Tue, Aug 17, 2021 at 1:19 PM Kang Joo <vfxc...@gmail.com> wrote:
Hello, the vray version I am currently using is v5.10.20. Does Golaem not currently support that version? If you plan to apply later, I wonder when you will apply.

--
Note that crowd...@golaem.com is a public list.
If for any reason (confidential project, sending production files...) you need to post a private message to Golaem Support, please use http://support.golaem.com
---
You received this message because you are subscribed to the Google Groups "Golaem List" group.
To unsubscribe from this group and stop receiving emails from it, send an email to crowd-list+...@golaem.com.
To view this discussion on the web visit https://groups.google.com/a/golaem.com/d/msgid/crowd-list/bc6f7c7e-8c3c-44f9-8993-5d983deaa285n%40golaem.com.

Kang Joo

unread,
Aug 19, 2021, 4:55:41 AMAug 19
to Golaem List, nicolas.chaverou
I don't think it's working.

I'm currently conducting a related test in the PLE version, but isn't vrscene data selected in the PLE version?

2021년 8월 17일 화요일 오후 8시 22분 47초 UTC+9에 nicolas.chaverou님이 작성:

Nicolas Chaverou

unread,
Aug 19, 2021, 5:21:18 AMAug 19
to Golaem List
Hey there

On Thu, Aug 19, 2021 at 10:56 AM Kang Joo <vfxc...@gmail.com> wrote:
I don't think it's working.

I'm currently conducting a related test in the PLE version, but isn't vrscene data selected in the PLE version?

Which version of Golaem are you using ?
If using Golaem < 7.3.11, it's required to install the plugin for Vray 5 to make it work with Vray 5.1

Golaem 7.3.11 is already fine

Just tried Vray 5 update 1.1 on my side and it's working fine

2021-08-19 11_13_38-V-Ray Frame Buffer - [100.0% of 960 x 540].png

Let us know if you have a different behavior on your side
Best,
 

Kang Joo

unread,
Aug 19, 2021, 5:40:08 AMAug 19
to Golaem List, nicolas.chaverou

Copy the vray_glmCrowdVRayXXPlugin plugin from ./procedurals/vray/compatibility/ to ./procedurals/vray/ and rename it to vray_glmCrowdVRayPlugin


Here in this sentence...

vray_glmCrowdVRayXXPlugin --> Where is this thing?
2021년 8월 19일 목요일 오후 6시 21분 18초 UTC+9에 nicolas.chaverou님이 작성:

Nicolas Chaverou

unread,
Aug 19, 2021, 5:53:59 AMAug 19
to Kang Joo, Golaem List
Hey there,

Those files are in the Golaem installation folder

and in the procedurals/vray/compatibility as stated in the doc
On my side

2021-08-19 11_53_02-compatibility.png

Kang Joo

unread,
Aug 23, 2021, 4:17:45 AMAug 23
to Golaem List, nicolas.chaverou, Golaem List, Kang Joo
Do I have to use the licensed version of vray when I pull it out with vrscene?

We are testing with a version that is not licensed, but vrscene is exported, but the data does not seem to be recorded

2021년 8월 19일 목요일 오후 6시 53분 59초 UTC+9에 nicolas.chaverou님이 작성:

Nicolas Chaverou

unread,
Aug 23, 2021, 5:03:12 AMAug 23
to Kang Joo, Golaem List
Hey,

On Mon, Aug 23, 2021 at 10:17 AM Kang Joo <vfxc...@gmail.com> wrote:
Do I have to use the licensed version of vray when I pull it out with vrscene?

Can you please describe what you're trying to do exactly ?
I'm not really sure what you're expecting
Maybe that's something you need to check with the Chaos people and what their non license version allows
 
We are testing with a version that is not licensed, but vrscene is exported, but the data does not seem to be recorded

What data are you looking for exactly ?
Is it a process which worked with previous versions of Vray ?

Best,

Kang Joo

unread,
Aug 30, 2021, 5:55:35 AMAug 30
to Golaem List, nicolas.chaverou, Golaem List, Kang Joo
Wrong number of arguments on call to createVRsceneFromProxy

The following errors continue to appear: Is it a plug-in problem related to V-rays?




2021년 8월 23일 월요일 오후 6시 3분 12초 UTC+9에 nicolas.chaverou님이 작성:

Nicolas Chaverou

unread,
Aug 30, 2021, 8:13:21 AMAug 30
to Kang Joo, Golaem List
Hey there,

On Mon, Aug 30, 2021 at 11:55 AM Kang Joo <vfxc...@gmail.com> wrote:
Wrong number of arguments on call to createVRsceneFromProxy

When are you getting this error exactly ?
Can you please describe what you're trying to do exactly ? Which steps are leading to this error
 
The following errors continue to appear: Is it a plug-in problem related to V-rays?

The error above is Golaem related but we need to know when / how that happens so we can know how to help fixing it
Can you detail your process is bit more ?

Thanks
 

crowd vfx

unread,
Aug 30, 2021, 8:31:01 AMAug 30
to Nicolas Chaverou, Golaem List
I'm in the process of exporting vrscene after making cache. As shown in the document, I checked and set export vrscene in render setting of vray. Then, exporting vrscene results in the following error and the vrscene file is generated, but there seems to be no information.

2021년 8월 30일 월요일, Nicolas Chaverou <nicolas....@golaem.com>님이 작성:

Nicolas Chaverou

unread,
Aug 30, 2021, 8:33:36 AMAug 30
to crowd vfx, Golaem List
Hey there

On Mon, Aug 30, 2021 at 2:31 PM crowd vfx <vfxc...@gmail.com> wrote:
I'm in the process of exporting vrscene after making cache. As shown in the document,

Which document are you referring to exactly ? Can you share the link ?
 
I checked and set export vrscene in render setting of vray. Then, exporting vrscene results in the following error and the vrscene file is generated, but there seems to be no information.

Are you trying to export the whole scene as vrscene or only the crowd ?
What are the vrscene files for exactly ?

N.
 

crowd vfx

unread,
Aug 30, 2021, 11:21:10 AMAug 30
to Nicolas Chaverou, Golaem List
https://golaem.com/content/doc/golaem-crowd-documentation/rendering-vrscene-files

Please refer to the following link.


Additionally, I want to make only Crowd into vrscene.

Because the company pipeline thought one of the data to export to the lighting team was vrscene.

2021년 8월 30일 (월) 오후 9:33, Nicolas Chaverou <nicolas....@golaem.com>님이 작성:

Nicolas Chaverou

unread,
Aug 30, 2021, 12:39:30 PMAug 30
to crowd vfx, Golaem List
Hey there,

Made a video which shows how to export the vrscene included the crowd cache
Let's first make this work and we'll see after how to only export the crowds

Best,

Kang Joo

unread,
Aug 31, 2021, 4:44:58 AMAug 31
to Golaem List, nicolas.chaverou, Golaem List, Kang Joo

With reference to the video you sent me, I succeeded in rendering with V-ray in Maya scene.

And I managed to export to vrscene.

When I tested vrscene for rendering by importing it in vray, the following error message came out.

error : V-ray : VRayScene : Preview for Node "particle@node" is not supported [UNKOWN]
error : V-ray : VRayScene : Preview for Node "glmPopulations@node" is not supported [UNKOWN]
error : V-ray : VRayScene : Preview for Node "cacheProxy@node" is not supported [UNKOWN]
error : V-ray : VRayScene : Preview for Node "untitled_renderProxyShape1@node" is not supported [UNKOWN]


The above error message came out and was not rendered. What was the problem?
2021년 8월 31일 화요일 오전 1시 39분 30초 UTC+9에 nicolas.chaverou님이 작성:

Nicolas Chaverou

unread,
Aug 31, 2021, 4:49:07 AMAug 31
to Kang Joo, Golaem List
Hey there

See inlined below:

On Tue, Aug 31, 2021 at 10:44 AM Kang Joo <vfxc...@gmail.com> wrote:

With reference to the video you sent me, I succeeded in rendering with V-ray in Maya scene.

And I managed to export to vrscene.

When I tested vrscene for rendering by importing it in vray, the following error message came out.

error : V-ray : VRayScene : Preview for Node "particle@node" is not supported [UNKOWN]
error : V-ray : VRayScene : Preview for Node "glmPopulations@node" is not supported [UNKOWN]
error : V-ray : VRayScene : Preview for Node "cacheProxy@node" is not supported [UNKOWN]
error : V-ray : VRayScene : Preview for Node "untitled_renderProxyShape1@node" is not supported [UNKOWN]

The above error message came out and was not rendered. What was the problem?

Those nodes are Golaem locator nodes in the Maya scene and are not renderable
Maybe you can try removing them from the vrscene file and see what happens

Let us know how it goes
Best,

Kang Joo

unread,
Aug 31, 2021, 4:53:52 AMAug 31
to Golaem List, nicolas.chaverou, Golaem List, Kang Joo
Even if Golaem's Locator node can't be rendered, the crowd geometry can't be rendered either. Let me check again first.

First of all, the error message I left you isn't a big problem, is it?

2021년 8월 31일 화요일 오후 5시 49분 7초 UTC+9에 nicolas.chaverou님이 작성:

Nicolas Chaverou

unread,
Aug 31, 2021, 5:04:45 AMAug 31
to Kang Joo, Golaem List
Hey there

On Tue, Aug 31, 2021 at 10:53 AM Kang Joo <vfxc...@gmail.com> wrote:
Even if Golaem's Locator node can't be rendered, the crowd geometry can't be rendered either. Let me check again first.
First of all, the error message I left you isn't a big problem, is it?

It should not be an issue for the rest of the rendering
But if you render through Vray, you need to make the Golaem For Vray plugin available to vray
This means setting up the PATH / LD_LIBRARY_PATH and  VRAY_PLUGINS_x64 environment variables in your system

Kang Joo

unread,
Aug 31, 2021, 5:09:19 AMAug 31
to Golaem List, nicolas.chaverou, Golaem List, Kang Joo
Do I also need to download additional golf for vray? Is there a plug-in that you installed somewhere?

2021년 8월 31일 화요일 오후 6시 4분 45초 UTC+9에 nicolas.chaverou님이 작성:

Nicolas Chaverou

unread,
Aug 31, 2021, 5:15:51 AMAug 31
to Kang Joo, Golaem List
Hey there

On Tue, Aug 31, 2021 at 11:09 AM Kang Joo <vfxc...@gmail.com> wrote:
Do I also need to download additional golf for vray? Is there a plug-in that you installed somewhere?

This is the same plugin which is used by Golaem within Maya.
Maybe check the Rendering Workflow help for more information about how procedural rendering within Golaem works

And which environment variables are required and what value you should set them
 
Maybe you can try checking out with your pipeline department at your studio, they should be used to that kind of workflow
Best,
Reply all
Reply to author
Forward
0 new messages