mayaUssPlugin version issue

18 views
Skip to first unread message

Kang Joo

unread,
Sep 15, 2021, 3:20:45 AMSep 15
to Golaem List
Currently, the company is using Golaem 7.3.12. Vray is using 5.10.21.

The problem is that Maya is crash when MayaUsdPlugin 0.9.0 version is turned on while Golaem is on. As a result of checking the pipeline TD, we received feedback that the MayaUsdPlugin version supported by Golaem is low, causing a collision.

When can the 0.9.0 version and further 0.1.0.0 version be supported?

Nicolas Chaverou

unread,
Sep 15, 2021, 4:46:23 AMSep 15
to Golaem List
Hey there,

Can you please specify which OS and Maya version you're running so we can try reproduce the same issue (feel free to use http://support.golaem.com when starting a new thread to make sure to include all relevant details)
Also how do you get the Maya USD plugin ? Are you compiling it yourselves or are you getting it compiled from the Autodesk website ?

Golaem does not support MayaUSD specifically but USD alone.
We encapsulated our USD version in a specific manner which should not collide with other USD based plugins but maybe we missed something
Thus, Golaem does not have to support a specific version of MayaUSD but still be able to run along side.

Please provide environment details so we can check what's happening exactly


--
Note that crowd...@golaem.com is a public list.
If for any reason (confidential project, sending production files...) you need to post a private message to Golaem Support, please use http://support.golaem.com
---
You received this message because you are subscribed to the Google Groups "Golaem List" group.
To unsubscribe from this group and stop receiving emails from it, send an email to crowd-list+...@golaem.com.
To view this discussion on the web visit https://groups.google.com/a/golaem.com/d/msgid/crowd-list/2522e421-bc19-4b65-85f9-836dfaf4383dn%40golaem.com.

Kang Joo

unread,
Sep 15, 2021, 5:23:35 AMSep 15
to Golaem List, nicolas.chaverou
Maya version in use: 2020
OS : Linux
Golaem:7.3.12

The MayaUsdPlugin installation seems to be the same as the link below.
https://knowledge.autodesk.com/support/maya/learn-explore/caas/CloudHelp/cloudhelp/ENU/Maya-USD/files/Maya-USD-Plug-in/GUID-8FB49D7F-8651-47CE-80FC-5C940E568C97-html.html?st=mayausdplugin

It seems to be compiled on the Autodk website.

The problem is that in the process of setting up the company's Maya,
It is a process of setting programs such as Golaem and Vray according to the company pipeline.

If Golaem and MayaUsdPlugin load at the same time in the plugin manager, Maya will be turned off immediately due to the collision.

When I checked in this situation, I received feedback that the USD version supported by Golaem was low and caused a collision.


That's why I'm asking you about the version update.

2021년 9월 15일 수요일 오후 5시 46분 23초 UTC+9에 nicolas.chaverou님이 작성:

Nicolas Chaverou

unread,
Sep 15, 2021, 9:53:39 AMSep 15
to Kang Joo, Golaem List
Hey there,

Ok I tried on my side and was able to reproduce the issue with MayaUSD 0.9 / Golaem 7.3.12 on Linux
This having been said, according to the MayaUSD changelogs they fixed a couple of stuff in the latest versions and with MayaUSD 0.10, I'm able to load the 2 plugins at the same time (MayaUSD 0.10 and Golaem 7.3.12)
Can you check this on your end? I also tested MayaUSD 0.11 and 0.12 and they are both fine
Regarding 0.9.0 I'm afraid we can't really do anything on our side
Best,

Kang Joo

unread,
Sep 16, 2021, 5:50:53 AMSep 16
to Golaem List, nicolas.chaverou, Golaem List, Kang Joo

I delivered it to TD of four companies, and first of all, I decided not to use 0.9.0 internally.

Thank you.
2021년 9월 15일 수요일 오후 10시 53분 39초 UTC+9에 nicolas.chaverou님이 작성:
Reply all
Reply to author
Forward
0 new messages