Problem with sharing data between two endpoints - both Globus Connect Personal

144 views
Skip to first unread message

Andrey Bzikadze

unread,
Jun 23, 2020, 9:21:46 PM6/23/20
to User Discuss
Hello everyone,

I am trying to create a shared directory on an ubuntu server. For this matter I setup a Globus Connect Personal on this server (or should I have used Globus Connect Server?) and created an endpoint that shares a directory (I use a university-provided subscription). I share data with other users having Globus Connect Personal accounts (do not necessarily have subscriptions). To test the connection I am attempting to send data from my laptop (another endpoint) through the Globus web interface (here I use the same account with subscription, in case that's important). For a test case I am sending the exact same file several times. Sometimes it works just fine, but in other cases I receive the following error:

Error (transfer)
Endpoint: laptop (...)
Server: Globus Connect
File: ...
Command: RETR ...
Message: Fatal FTP response
---
Details: 500-Command failed. : an end-of-file was reached\r\n500-globus_xio: The GSI XIO driver failed to establish a connection via the underlying protocol.\r\n500-globus_xio: Connection setup failure: connection time out.\r\n500 End.\r\n

In cases the file can't be sent, globus attempts again until eventually the file is sent. I am suspecting that something is wrong with how the firewall is configured on the server:

-A TCP -p tcp -m tcp --dport 2223 -s 54.237.254.192/29 -j ACCEPT
-A TCP -p tcp -m tcp --dport 50000:51000 -j ACCEPT
-A UDP -p udp -m udp --dport 32768:65535 -j ACCEPT
-A UDP -p udp -m udp --dport 19302 -j ACCEPT

Thank you,
Andrey

Gigi Kennedy

unread,
Jul 2, 2020, 3:29:36 PM7/2/20
to user-d...@globus.org
Hi Andrey,

I've opened up a support ticket for you in our help desk. This will allow us to investigate in more detail. 

We can respond back to this email and share the resolution once we've resolved your issue.

Best regards,
  Gigi

Andrey Bzikadze

unread,
Jul 9, 2020, 4:34:53 PM7/9/20
to User Discuss, gi...@globus.org
Gigi, thank you for helping with this issue. I configured a GCS and do not observe errors anymore. No further assistance is needed. I would have answered in the ticket, but I get the following error

"oops
The page you were looking for doesn't exist

You may have mistyped the address or the page may have moved"

Please go ahead and mark ticket as resolved.

Thank you!

Andrey

Reply all
Reply to author
Forward
0 new messages