globusconnectpersonal error on ubuntu 18.04 LTS

6 views
Skip to first unread message

John R. Absher

unread,
Aug 16, 2020, 2:24:45 PM8/16/20
to User Discuss
Hi,

For some reason I cannot get globusconnectpersonal-3.1.1 to run under this OS. I've tried running with and without the gui, and keep getting the same error:

./globusconnect: line 168: 12254 Segmentation fault      (core dumped) "${GLOBUS_LOCATION}/bin/register" ${SETUP_ARGS[*]} 2> /dev/null

I've installed the tk tcllib, and I also executed this command (which I found on a related post):

jabsher@sphinx:~/Downloads/globusconnectpersonal-3.1.1$ !173
find gt_amd64 -exec ldd -r {} \; |grep not\ found
ldd: ./gt_amd64: not regular file
ldd: gt_amd64/lib: not regular file
ldd: gt_amd64/lib/globus: not regular file
ldd: gt_amd64/sbin: not regular file
ldd: gt_amd64/bin: not regular file

Any suggestions how to get this installed? Do I need to have a VPN running to get this to work, as I have that on my Windows 10 PC that uses globus?

Thanks,

John

Stephen Rosen

unread,
Aug 17, 2020, 11:14:13 AM8/17/20
to User Discuss
Hi John,

Sorry you're running into this issue.

The crash failure is happening when trying to run the "register" binary, but it's not clear what the cause is.
Could you try running again with the following arguments?

  ./globusconnectpersonal -setup --debug --no-gui

I'm curious to learn if `register` is starting up correctly and hitting a segfault later, or if it fails to even start.
If it's running at all, I would expect some debug output to show up. If there's no output at all, don't worry -- please just let me know and we'll go from there.

I'd also appreciate your sharing `uname -a`, just to ensure you're not running on an unsupported architecture (e.g. arm64).


Globus Connect Personal setup isn't even reaching network communication steps in your case, so you don't need to worry about your network configuration.

Best,
-Stephen

John R. Absher

unread,
Aug 17, 2020, 12:32:57 PM8/17/20
to user-d...@globus.org
Ah, it may well be the amd64 architecture....  I’ll run those steps tonight (it’s my home computer) and let you know. The log file was empty after I ran debug. 

--


To unsubscribe from this group and stop receiving emails from it, send an email to user-discuss...@globus.org.


Reply all
Reply to author
Forward
0 new messages