HMAC secret timing out v2.0 tests but passing v2.1

43 views
Skip to first unread message

Gerard Green

unread,
Feb 7, 2022, 1:03:08 AMFeb 7
to fido...@fidoalliance.org
Hi,

I'm testing my Fido2 authenticator using Conformance Tool 1.5.2. It passes most Fido 2.0 tests but fails Extensions - HMAC secret. The test times out in P-4 after 60s.

Is the 60s timeout a requirement? Is it possible to increase the timeout? Or do I have a bug?

My authenticator passes the 2.1 HMAC tests in 1.6.41.

regards
Gerry


Ackermann Yuriy

unread,
Feb 7, 2022, 1:39:42 AMFeb 7
to Gerard Green, fido...@fidoalliance.org
Hey Gerry.

You can try CTAP2.0 tests in 1.6.41 as well

--
You received this message because you are subscribed to the Google Groups "FIDO Dev (fido-dev)" group.
To unsubscribe from this group and stop receiving emails from it, send an email to fido-dev+u...@fidoalliance.org.
To view this discussion on the web visit https://groups.google.com/a/fidoalliance.org/d/msgid/fido-dev/CADtj%2BdETQ%2BATXdBT_us09f%2B7uhU1DFtt1z60_FeVxTJXduDJ9Q%40mail.gmail.com.
--
Yuriy Ackermann
FIDO, Identity, Standards
skype: ackermann.yuriy
github: @herrjemand
twitter: @herrjemand
medium: @herrjemand

Gerard Green

unread,
Feb 13, 2022, 4:45:21 PMFeb 13
to Ackermann Yuriy, fido...@fidoalliance.org
Hi Yuriy,
Can you see from the log what I am doing wrong?

kind regards
Gerry


On Tue, Feb 8, 2022 at 1:41 PM Gerard Green <gerr...@gmail.com> wrote:
Hi Yuriy,

did that log make any sense? Was it the correct one?

regards
Gerry


On Mon, Feb 7, 2022 at 7:10 PM Gerard Green <gerr...@gmail.com> wrote:
Yuriy,

here it is

regards
Gerry



On Mon, Feb 7, 2022 at 6:55 PM Ackermann Yuriy <ackerma...@gmail.com> wrote:
Menu -> Open Inspector

On Mon, 7 Feb 2022 at 11:18 AM, Gerard Green <gerr...@gmail.com> wrote:
Yuriy,

You mean logs from the Conformance Tool? Where are those logs located?

kind regards
Gerry

 

On Mon, Feb 7, 2022 at 5:52 PM Ackermann Yuriy <ackerma...@gmail.com> wrote:
Can you share with exchange logs?

On Mon, 7 Feb 2022 at 10:51 AM, Gerard Green <gerr...@gmail.com> wrote:
Hi Yuriy,
Thanks for your _very_ quick reply!

As you suggest, I just tried v2.0 legacy tests with v1.6.41 and got the following result.

I guess the v2.1 HMAC test must be different in some way.

image.png

thanks
Gerry

Reply all
Reply to author
Forward
0 new messages