[M] Change in dart/sdk[main]: Extra testing of inet_pton.

0 views
Skip to first unread message

Lasse Nielsen (Gerrit)

unread,
Jul 13, 2026, 11:35:08 AM (3 days ago) Jul 13
to Martin Kustermann, dart-...@luci-project-accounts.iam.gserviceaccount.com, rev...@dartlang.org, vm-...@dartlang.org
Attention needed from Lasse Nielsen and Martin Kustermann

Lasse Nielsen voted and added 2 comments

Votes added by Lasse Nielsen

Commit-Queue+1

2 comments

Patchset-level comments
File-level comment, Patchset 2 (Latest):
Lasse Nielsen . resolved

I think this makes the test succeed on Android/MacOS.

(But at this point, we might as well write out own IPv4 parser instead of calling `inet_pton` and then scanning the source again. `Uri` already has one in Dart.)

File-level comment, Patchset 2 (Latest):
Lasse Nielsen . resolved

I think this makes the test succeed on mac/android.

Open in Gerrit

Related details

Attention is currently required from:
  • Lasse Nielsen
  • Martin Kustermann
Submit Requirements:
  • requirement is not satisfiedCode-Owners
  • requirement is not satisfiedCode-Review
  • requirement is not satisfiedCommit-Message-Has-TEST
  • requirement is not satisfiedReview-Enforcement
Inspect html for hidden footers to help with email filtering. To unsubscribe visit settings. DiffyGerrit
Gerrit-MessageType: comment
Gerrit-Project: sdk
Gerrit-Branch: main
Gerrit-Change-Id: Icb34d452e255f0c407fc872ed81e9ffa06fc3a8a
Gerrit-Change-Number: 523600
Gerrit-PatchSet: 2
Gerrit-Owner: Lasse Nielsen <l...@google.com>
Gerrit-Reviewer: Lasse Nielsen <l...@google.com>
Gerrit-Reviewer: Martin Kustermann <kuste...@google.com>
Gerrit-Attention: Martin Kustermann <kuste...@google.com>
Gerrit-Attention: Lasse Nielsen <l...@google.com>
Gerrit-Comment-Date: Mon, 13 Jul 2026 15:35:05 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
unsatisfied_requirement
open
diffy

Martin Kustermann (Gerrit)

unread,
Jul 15, 2026, 3:47:02 PM (12 hours ago) Jul 15
to Lasse Nielsen, dart-...@luci-project-accounts.iam.gserviceaccount.com, rev...@dartlang.org, vm-...@dartlang.org
Attention needed from Lasse Nielsen

Martin Kustermann voted and added 2 comments

Votes added by Martin Kustermann

Code-Review+1

2 comments

File runtime/bin/socket_base.h
Line 375, Patchset 5 (Latest): // Digit following zero is only failure condition.
Martin Kustermann . unresolved

Cannot say this is easy to read and maybe it's not that performance critical. You could consider writing this a bit simpler.

Line 366, Patchset 5 (Latest): const int no_digit_state = -1;
Martin Kustermann . unresolved

nit: I think we use `kNoDigitState` naming convention for constants in C++

Open in Gerrit

Related details

Attention is currently required from:
  • Lasse Nielsen
Submit Requirements:
  • requirement satisfiedCode-Owners
  • requirement satisfiedCode-Review
  • requirement satisfiedCommit-Message-Has-TEST
  • requirement satisfiedReview-Enforcement
Inspect html for hidden footers to help with email filtering. To unsubscribe visit settings. DiffyGerrit
Gerrit-MessageType: comment
Gerrit-Project: sdk
Gerrit-Branch: main
Gerrit-Change-Id: Icb34d452e255f0c407fc872ed81e9ffa06fc3a8a
Gerrit-Change-Number: 523600
Gerrit-PatchSet: 5
Gerrit-Owner: Lasse Nielsen <l...@google.com>
Gerrit-Reviewer: Lasse Nielsen <l...@google.com>
Gerrit-Reviewer: Martin Kustermann <kuste...@google.com>
Gerrit-Attention: Lasse Nielsen <l...@google.com>
Gerrit-Comment-Date: Wed, 15 Jul 2026 19:46:56 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
satisfied_requirement
open
diffy

Ryan Macnak (Gerrit)

unread,
Jul 15, 2026, 7:29:44 PM (8 hours ago) Jul 15
to Lasse Nielsen, Martin Kustermann, dart-...@luci-project-accounts.iam.gserviceaccount.com, rev...@dartlang.org, vm-...@dartlang.org
Attention needed from Lasse Nielsen

Ryan Macnak added 2 comments

Commit Message
Line 13, Patchset 5 (Latest):Windows, Fuchsia, Linux with GLIBC, uClibc or Muse
Ryan Macnak . unresolved

musl

File runtime/bin/socket_base.h
Line 17, Patchset 5 (Latest):#define _INET_PTON_FLAWED
Ryan Macnak . unresolved

nit: Remove leading underscore. Identifiers starting with __ or _ followed by an uppercase letter are reserved for the C compiler.

Open in Gerrit

Related details

Attention is currently required from:
  • Lasse Nielsen
Submit Requirements:
  • requirement satisfiedCode-Owners
  • requirement satisfiedCode-Review
  • requirement satisfiedCommit-Message-Has-TEST
  • requirement satisfiedReview-Enforcement
Inspect html for hidden footers to help with email filtering. To unsubscribe visit settings. DiffyGerrit
Gerrit-MessageType: comment
Gerrit-Project: sdk
Gerrit-Branch: main
Gerrit-Change-Id: Icb34d452e255f0c407fc872ed81e9ffa06fc3a8a
Gerrit-Change-Number: 523600
Gerrit-PatchSet: 5
Gerrit-Owner: Lasse Nielsen <l...@google.com>
Gerrit-Reviewer: Lasse Nielsen <l...@google.com>
Gerrit-Reviewer: Martin Kustermann <kuste...@google.com>
Gerrit-CC: Ryan Macnak <rma...@google.com>
Gerrit-Comment-Date: Wed, 15 Jul 2026 23:29:40 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
satisfied_requirement
open
diffy
Reply all
Reply to author
Forward
0 new messages