We're making a breaking change where dart pub get/flutter pub get/pub get
will start to throw an error when resolving a pubspec.yaml
file for an app, if the pubspec doesn't contain a Dart SDK constraint
Most pubspec.yaml files already contain such a constraint, so the expected impact is small. But we recommend you check, and add the constraint if missing, e.g.
sdk: '>=2.10.0 <3.0.0'
The change is being made for the Dart 2.12 release.
For more details, please see:https://github.com/dart-lang/sdk/issues/44072