Breaking change 44072: Apps must declare an SDK constraint in pubspec.yaml

296 views
Skip to first unread message

Michael Thomsen

unread,
Nov 5, 2020, 10:17:02 AM11/5/20
to Dart Announcements
We're making a breaking change where dart pub get/flutter pub get/pub get will start to throw an error when resolving a pubspec.yaml file for an app, if the pubspec doesn't contain a Dart SDK constraint.

Most pubspec.yaml files already contain such a constraint, so the expected impact is small. But we recommend you check, and add the constraint if missing, e.g.

environment:
  sdk: '>=2.10.0 <3.0.0'

The change is being made for the Dart 2.12 release.

For more details, please see:
https://github.com/dart-lang/sdk/issues/44072

Reply all
Reply to author
Forward
This conversation is locked
You cannot reply and perform actions on locked conversations.
0 new messages