breaking change 45451: deprecate and remove support for native extensions

37 views
Skip to first unread message

Slava Egorov

unread,
May 3, 2021, 10:52:46 AMMay 3
to anno...@dartlang.org, General Dart Discussion
We are planning to deprecate (in Dart 2.14) and remove (in Dart 2.15) support for native extensions. Users are expected to migrate to dart:ffi instead.

This breaking change implies removal of support for the dart-ext import scheme as well as hiding the Dart VM C API in dart binaries. Users are expected to migrate to FFI based bindings, which come with a variety of benefits (they are more performant and AOT compilation friendly).

Flutter has never supported native extensions, so we don't expect any significant usage to exist in the wild. 

See official breaking change request: github.com/dart-lang/sdk/issues/45451

Please let us know if you have any concerns with this change.


Reply all
Reply to author
Forward
0 new messages