breaking change #46545: dropping support for ES5

73 views
Skip to first unread message

Siggi Cherem

unread,
Jul 1, 2021, 8:21:53 PMJul 1
to anno...@dartlang.org
Two years ago we announced a plan to deprecate support for ES5. Changes in priorities made us delay our plans until now.

In an upcoming Dart release, dart2js will by default start generating code that uses ES6 features and as a result apps will no longer work in older browsers like IE11 that lack such features.

You can find details and provide feedback at https://github.com/dart-lang/sdk/issues/46545
Reply all
Reply to author
Forward
0 new messages