breaking change #46316: removing WebSQL

33 views
Skip to first unread message

Siggi Cherem

unread,
Jun 9, 2021, 12:26:29 PMJun 9
to anno...@dartlang.org
The WebSQL standard was abandoned many years ago and is not supported by many browsers. Our corresponding APIs (`dart:web_sql` and `window.openDatabase` from `dart:html`) are unsupported. In Dart 2.14 they will be marked deprecated and we plan to remove them in a future release, likely Dart 2.15.

You can find details and provide feedback at https://github.com/dart-lang/sdk/issues/46316
Reply all
Reply to author
Forward
0 new messages