[dart-announce] BREAKING CHANGE: HttpBodyHandler, HttpMultipartFormData and MimeMultipartTransformer moved from dart:io to packages.

Showing 1-1 of 1 messages
[dart-announce] BREAKING CHANGE: HttpBodyHandler, HttpMultipartFormData and MimeMultipartTransformer moved from dart:io to packages. Anders Johnsen 7/15/13 1:57 AM

BREAKING CHANGE!

What changed?

HttpBodyHandler and HttpMultipartFormData was moved to package 'http_server' and MimeMultipartTransformer was moved to package 'mime'.

Who is affected?

Some users of dart:io, using the classes mentioned.

How do I update my code?

As the classes are now available through a package, simply update your pubspec with a dependency to http_server/mime and add the package import.

Why did this change happen?

These classes provided a very specific high-level API, that didn't fit the dart:io library. Such high-level classes should be in a package.

When will the change take effect?

The change will take effect on Monday after revision r24991.

Where can I learn more?

Check http://pub.dartlang.org/packages/mime and http://pub.dartlang.org/packages/http_server for more info about the packages.

--
For more news and information, visit http://news.dartlang.org/
 
To join the conversation, visit https://groups.google.com/a/dartlang.org/