Problems installing cupy - downgrade to 3.7?

12 views
Skip to first unread message

Jeffrey Layton

unread,
Nov 17, 2020, 7:59:29 AM11/17/20
to anaconda
Good morning,

I'm trying to install cupy on my fresh Anaconda install and I'm getting the following errors:


$ conda install -c anaconda cupy
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: /
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.
failed                                                                                                                              

UnsatisfiableError: The following specifications were found
to be incompatible with the existing python installation in your environment:

Specifications:

  - cupy -> python[version='>=2.7,<2.8.0a0|>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.5,<3.6.0a0']

Your python: python=3.8

If python is on the left-most side of the chain, that's the version you've asked for.
When python appears to the right, that indicates that the thing on the left is somehow
not available for the python version you are constrained to. Note that conda will not
change your python version to a different minor version unless you explicitly specify
that.



I'm guessing that there is no build of cupy for 3.8 bnut there is for 3.7. How can I downgrade to Python 3.7?

Thanks!

Jeff


Reply all
Reply to author
Forward
0 new messages