Python-control Package wincertstore conflicts found with win 32 installation with Python 3.7

7 views
Skip to first unread message

Jesús Ramírez

unread,
Nov 21, 2020, 4:49:16 AM11/21/20
to anac...@continuum.io
Hello Community.

I have an issue to install of Python-control package
 in python 3.7


Attach the infoirmation after  after installation:

>>>



(base) C:\Users\Ing. JESUS RAMIREZ>conda install -c conda-forge control
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible so
lve.
Solving environment: failed with repodata from current_repodata.json, will retry
 with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible so
lve.
Solving environment: -
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.
Finding conflicts:   0%|                                | 0/80 [00:00<?, ?it/s]/
Examining python:   5%|¦?                       | 4/80 [00:00<00:01, 68.96it/-
Comparing specs - at have this dependency:   0%|         | 0/2 [00:00<?, ?it/s]
Finding shortest conflict path for python[version='>=3.5,<3.6.0a0']:   0%| | 0/1
Finding shortes/ conflict path for python[version='<=3.3']:   7%| | 1/14 [00:00<
Finding shortest conflict path for python[version='<=3.3']:  14%|?| 2/14 [00:00<
Fin| ng shortest conflict path for python=2.7:  14%|?| 2/14 [08:46<00:03,  3.91i
Finding shortest conflict path for python=2.7:  21%|?| 3/14 [08:46<28:58, 158.09
\ nding shortest conflict path for python:  21%|?| 3/14 [08:47<28:58, 158.09s/it
Finding shortest conflict path for python:  29%|?| 4/14 [08:47<18:27, 110.78s/it
Finding short| t conflict path for python[version='<3']:  29%|?| 4/14 [09:13<18:
Finding shortest conflict path for python[version='<3']:  36%|?| 5/14 [09:13<12:
Fi| ing shortest conflict path for python=3.6:  36%|?| 5/14 [09:55<12:49, 85.45s
Finding shortest conflict path for python=3.6:  43%|?| 6/14 [09:55<09:39, 72.49s
Fi\ ing shortest conflict path for python=3.5:  43%|?| 6/14 [09:56<09:39, 72.49s
Finding shortest conflict path for python=3.5:  50%|¦| 7/14 [09:56<05:56, 50.87s
Findin| shortest conflict path for msgpack-python:  50%|¦| 7/14 [09:56<05:56, 50
Finding shortest conflict path for msgpack-python:  57%|¦| 8/14 [09:56<03:34, 35
Finding shortest conflict| ath for python[version='>=2.7,<2.8.0a0']:  57%|¦| 8/1
Finding shortest conflict path for python[version='>=2.7,<2.8.0a0']:  64%|?| 9/1
Finding shortes| conflict path for python[version='>=3']:  64%|?| 9/14 [22:49<21
Finding shortest conflict path for python[version='>=3']:  71%|?| 10/14 [22:49<1
Finding s\ rtest conflict path for python-dateutil:  71%|?| 10/14 [23:18<11:59,
Finding shortest conflict path for python-dateutil:  79%|?| 11/14 [23:18<06:43,
Fi\ ing shortest conflict path for python=3.7:  79%|?| 11/14 [23:18<06:43, 134.4
Finding shortest conflict path for python=3.7:  86%|?| 12/14 [23:18<03:08, 94.36
Finding shortest conflict -  h for python[version='>=3.6,<3.7.0a0']:  86%|?| 12/
Finding shortest conflict path for python[version='>=3.6,<3.7.0a0']:  93%|?| 13/
Finding shortest/ onflict path for python[version='<4.0']:  93%|?| 13/14 [31:35<
Finding shortest conflict path for python[version='<4.0']: 100%|¦| 14/14 [31:35<
- mparing specs that have this dependency:  50%|¦| 1/2 [39:52<39:52, 2392.72s/it
]
Finding shortest conflict path for python[version='>=3.5,<3.6.0a0']:   0%| | 0/1
Finding shortest c\ flict path for python=2.7:  10%| | 1/10 [00:00<00:00, 58.82i
Finding shortest conflict path for python:  20%|?| 2/10 [00:00<00:00, 58.82it/s]
Finding shortest conflict path for python=3.6:  30%|?| 3/10 [00:00<00:00, 61.22i
Finding shortest conflict path for python=3.5:  40%|?| 4/10 [00:00<00:00, 61.54i
Finding shortest conflict path for python[version='>=2.7,<2.8.0a0']:  50%|¦| 5/1
Finding shortest conflict path for python[version='>=3']:  60%|¦| 6/10 [00:00<00
Finding short| t conflict path for python[version='>=3']:  70%|?| 7/10 [00:00<00
Finding shortest conflict path for python=3.7:  70%|?| 7/10 [00:00<00:00, 60.87i
Finding shortest conflict path for python[version='>=3.6,<3.7.0a0']:  80%|?| 8/1
Finding shortest conflict path for python[version='>=3.7,<3.8.0a0']:  90%|?| 9/1
Comparing specs that have this dependency: 100%|¦| 2/2 [39:53<00:00, 1196.52s/it
Examining six:  12%|¦¦¦                     | 10/80 [39:53<7:45:21, 398.88s/it]/
Examining tbb:  40%|¦¦¦¦¦¦¦¦¦¦              | 32/80 [39:54<3:43:23, 279.23s/it]/
Examining wincertstore:  50%|¦¦¦¦¦¦¦¦       | 40/80 [39:54<3:06:09, 279.23s/i-
Comparing sp| s that have this dependency:   0%|         | 0/2 [00:00<?, ?it/s]
Finding shortest conflict path for wincertstore[version='>=0.2']:   0%| | 0/2 [0
Fin/ ng shortest conflict path for wincertstore:  50%|¦| 1/2 [00:51<00:51, 51.23
Finding shortest conflict path for wincertstore: 100%|¦| 2/2 [00:51<00:00, 25.62
Comparing specs that have this dependency:  50%|¦| 1/2 [01:43<01:43, 103.27s/it]
              /
Finding shorte-  conflict path for wincertstore[version='>=0.2']:   0%| | 0/1 [0
Examining freetype:  96%|¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦?| 77/80 [41:40<09:53, 197.72s/it]\
failed

UnsatisfiableError: The following specifications were found
to be incompatible with the existing python installation in your environment:

Specifications:

  - control -> python[version='2.7.*|3.5.*|3.6.*']

Your python: python=3.7

If python is on the left-most side of the chain, that's the version you've asked
 for.
When python appears to the right, that indicates that the thing on the left is s
omehow
not available for the python version you are constrained to. Note that conda wil
l not
change your python version to a different minor version unless you explicitly sp
ecify
that.

The following specifications were found to be incompatible with each other:



Package wincertstore conflicts for:
control -> matplotlib -> setuptools -> wincertstore[version='>=0.2']
python=3.7 -> pip -> setuptools -> wincertstore[version='>=0.2']
Package setuptools conflicts for:
python=3.7 -> pip -> setuptools
control -> matplotlib -> setuptools
Package msgpack-python conflicts for:
control -> python=3.5 -> pip -> cachecontrol -> msgpack-python
Package python-dateutil conflicts for:
control -> matplotlib -> python-dateutil


I'll apreciate very much tour help to solve the conflicts

Sincerely
Jesús  Ramirez
Reply all
Reply to author
Forward
0 new messages