UnicodeDecodeError when importing vispy

1 view
Skip to first unread message

Andrea Cogliati

unread,
Nov 11, 2020, 2:45:36 PM11/11/20
to Anaconda - Public
I'm getting the following error while importing vispy subpackages, such as vispy.scene:

(gdocm4d) PS C:\Users\Andrea Cogliati\Documents\LighTopTech\4D-Qt5-Gui> python .\vptest.py
Traceback (most recent call last):
  File ".\vptest.py", line 1, in <module>
    from vispy import scene
  File "C:\Users\Andrea Cogliati\anaconda3\envs\gdocm4d\lib\site-packages\vispy\scene\__init__.py", line 33, in <module>
    from .visuals import *  # noqa
  File "C:\Users\Andrea Cogliati\anaconda3\envs\gdocm4d\lib\site-packages\vispy\scene\visuals.py", line 18, in <module>
    from .. import visuals
  File "C:\Users\Andrea Cogliati\anaconda3\envs\gdocm4d\lib\site-packages\vispy\visuals\__init__.py", line 14, in <module>
    from .axis import AxisVisual  # noqa
  File "C:\Users\Andrea Cogliati\anaconda3\envs\gdocm4d\lib\site-packages\vispy\visuals\axis.py", line 11, in <module>
    from .visual import CompoundVisual
  File "C:\Users\Andrea Cogliati\anaconda3\envs\gdocm4d\lib\site-packages\vispy\visuals\visual.py", line 90, in <module>
    from .. import gloo
  File "C:\Users\Andrea Cogliati\anaconda3\envs\gdocm4d\lib\site-packages\vispy\gloo\__init__.py", line 47, in <module>
    from . import gl  # noqa
  File "C:\Users\Andrea Cogliati\anaconda3\envs\gdocm4d\lib\site-packages\vispy\gloo\gl\__init__.py", line 34, in <module>
    from ._constants import *  # noqa
  File "C:\Users\Andrea Cogliati\anaconda3\envs\gdocm4d\lib\site-packages\vispy\gloo\gl\_constants.py", line 326, in <module>
    if repr(ob).startswith('GL_'):
  File "C:\Users\Andrea Cogliati\anaconda3\envs\gdocm4d\lib\_sitebuiltins.py", line 61, in __repr__
    self.__setup()
  File "C:\Users\Andrea Cogliati\anaconda3\envs\gdocm4d\lib\_sitebuiltins.py", line 51, in __setup
    data = fp.read()
  File "C:\Users\Andrea Cogliati\anaconda3\envs\gdocm4d\lib\encodings\cp1252.py", line 23, in decode
    return codecs.charmap_decode(input,self.errors,decoding_table)[0]
UnicodeDecodeError: 'charmap' codec can't decode byte 0x9d in position 188: character maps to <undefined>

The problem only started to occur recently, and I'm not sure what I may have changed to cause it to happen. Any suggestions?
Reply all
Reply to author
Forward
0 new messages