rstudio cannot be installed on this environment (Anaconda3 on Windows 10)

16 views
Skip to first unread message

Dawei Li

unread,
Dec 12, 2020, 7:06:14 AM12/12/20
to Anaconda - Public

I am on Windows 10, and have installed Anaconda3 individual edition (version 2020.11, latest as of Dec. 12, 2020). I want to install RStudio inside Anaconda3 using the Anaconda Navigator.

I created a new environment called renv (also tried rstudio, renv2, etc) and checked both Python (3.8) and r. Then, I tried to install RStudio on this environment. Unfortunately, I always got this error: rstudio cannot be installed on this environment. It asks me whether I'd like to create a new environment (which is exactly what I have done). So, I created a new environment and the same error occurred, over and over again.

Some things I have tried so far:

  • Tried installing for all user
  • Tried installing only for me
  • Tried running the exe installer as a normal user
  • Tried running the exe installer as an administrator
  • Tried checking "using Anaconda3 as the system Python3"
  • Tried unchecking "using Anaconda3 as the system Python3"

No luck in resolving the issue... I had this problem several months back, hoped new releases will not have the problem. Unfortunately, the error persists.

Can someone help? Could you fix this problem?

David Kun

unread,
Jan 8, 2021, 10:56:27 PMJan 8
to Anaconda - Public, douglasleer
For me, it seems that installing rstudio is somewhat finicky on Windows 10.  However, I got rstudio to install using the Anaconda prompt as follows:

> conda create -n renv python=3.7 -y
> conda activate renv
> conda install rstudio
> rstudio


I've never used rstudio but I was able to get the Rstudio GUI to appear when running "rstudio".

Note, conda version is 4.7.12 = 2019-09-12.  python version 3.7.1.  

Hope that helps and good luck!

Reply all
Reply to author
Forward
0 new messages