AttributeError: module 'jedi' has no attribute 'settings'

1 view
Skip to first unread message

Stephen Davies

unread,
Nov 12, 2020, 2:12:33 PM11/12/20
to Anaconda - Public
Hello all, I'm pulling my hair out.

I just tried to install Anaconda 3-2020.07 from scratch on my Ubuntu 18.04 laptop. It seemed to install okay, but whenever I try to run Spyder (by typing "spyder" on the command-line), I get a bunch of barfy messages culminating in something about module "jedi" (see below).

I'm not trying to do anything cool or complicated; just install from scratch the most recent version of Anaconda, and bring up Spyder. Can someone give me a clue as to what to look for here? (My environment is called "sanity", and I've tried both "conda remove -m sanity jedi" and "conda install -m sanity jedi" to try and brute force my way through it, but to no avail.)

It is true that I have used an older version of Anaconda on this machine previously, and maybe some old configuration pieces are still being used. What I want to do is just obliterate anything old and just enter into my new life with the latest Anaconda.


$ spyder
Traceback (most recent call last):
  File "/opt/anaconda3/bin/spyder", line 11, in <module>
    sys.exit(main())
  File "/opt/anaconda3/lib/python3.8/site-packages/spyder/app/start.py", line 205, in main
    mainwindow.main()
  File "/opt/anaconda3/lib/python3.8/site-packages/spyder/app/mainwindow.py", line 3763, in main
    mainwindow = run_spyder(app, options, args)
  File "/opt/anaconda3/lib/python3.8/site-packages/spyder/app/mainwindow.py", line 3638, in run_spyder
    main.setup()
  File "/opt/anaconda3/lib/python3.8/site-packages/spyder/app/mainwindow.py", line 945, in setup
    from spyder.plugins.ipythonconsole.plugin import IPythonConsole
  File "/opt/anaconda3/lib/python3.8/site-packages/spyder/plugins/ipythonconsole/plugin.py", line 46, in <module>
    from spyder.plugins.ipythonconsole.widgets import (ClientWidget,
  File "/opt/anaconda3/lib/python3.8/site-packages/spyder/plugins/ipythonconsole/widgets/__init__.py", line 16, in <module>
    from .debugging import DebuggingWidget
  File "/opt/anaconda3/lib/python3.8/site-packages/spyder/plugins/ipythonconsole/widgets/debugging.py", line 15, in <module>
    from IPython.core.history import HistoryManager
  File "/opt/anaconda3/lib/python3.8/site-packages/IPython/__init__.py", line 56, in <module>
    from .terminal.embed import embed
  File "/opt/anaconda3/lib/python3.8/site-packages/IPython/terminal/embed.py", line 16, in <module>
    from IPython.terminal.interactiveshell import TerminalInteractiveShell
  File "/opt/anaconda3/lib/python3.8/site-packages/IPython/terminal/interactiveshell.py", line 35, in <module>
    from .debugger import TerminalPdb, Pdb
  File "/opt/anaconda3/lib/python3.8/site-packages/IPython/terminal/debugger.py", line 8, in <module>
    from IPython.core.completer import IPCompleter
  File "/opt/anaconda3/lib/python3.8/site-packages/IPython/core/completer.py", line 147, in <module>
    jedi.settings.case_insensitive_completion = False
AttributeError: module 'jedi' has no attribute 'settings'

Reply all
Reply to author
Forward
0 new messages