Anaconda3 and nodejs

8 views
Skip to first unread message

Pete Seel

unread,
Jan 10, 2021, 3:16:49 PMJan 10
to Anaconda - Public
Hello,

I have a fresh install of Centos 8 with Anaconda3 in /opt/anaconda3 from install package Anaconda3-2020.11. The problem which I've been struggling with today is that to use extensions within Jupyterlab the version of nodejs needs to be greater than 10. I am trying to stick with Conda as a package manager but conda install nodejs won't take the version past v6.11.2. I've also tried conda install -c conda-forge nodejs  but this fails after a few hours.

Can anyone suggest how to upgrade nodejs to a version greater than 10 in a stock anaconda3 install without breaking future conda dependencies? 

Thanks

(base) [pete.seel@hobbit /]$ conda info

active environment : base
active env location : /opt/anaconda3
shell level : 1
user config file : /home/pete.seel/.condarc
populated config files :
conda version : 4.9.2
conda-build version : 3.20.5
python version : 3.8.5.final.0
virtual packages : __cuda=11.2=0
__glibc=2.28=0
__unix=0=0
__archspec=1=x86_64
base environment : /opt/anaconda3 (writable)
channel URLs : https://repo.anaconda.com/pkgs/main/linux-64
https://repo.anaconda.com/pkgs/main/noarch
https://repo.anaconda.com/pkgs/r/linux-64
https://repo.anaconda.com/pkgs/r/noarch
package cache : /opt/anaconda3/pkgs
/home/pete.seel/.conda/pkgs
envs directories : /opt/anaconda3/envs
/home/pete.seel/.conda/envs
platform : linux-64
user-agent : conda/4.9.2 requests/2.25.1 CPython/3.8.5 Linux/4.18.0-259.el8.x86_64 centos/8 glibc/2.28
UID:GID : 1000:100
netrc file : None
offline mode : False
Reply all
Reply to author
Forward
0 new messages