Package conflicts right after fresh install

13 views
Skip to first unread message

Fernando Luco

unread,
Nov 16, 2020, 5:51:08 PM11/16/20
to Anaconda - Public
Hello,

I just installed Ubuntu 20.10 and, after doing system upgrades, I downloaded Anaconda3-2020.07-Linux-x86_64.sh. After installation, the *only* package I tried to install was Geopandas and the conda installer first wouldn't install it and then it simply identified many, many conflicts and spent hours looking for incompatible packages. Again, this was following fresh installs of both the OS and Anaconda. For example, the following are part of the problems identified by the installer (I can't past all of it as the original message was so long that the terminal doesn't show it anymore).

I wold appreciate any suggestions on what to do. Thanks

--- Example of output ---
Package harfbuzz conflicts for:
pango -> harfbuzz[version='>=1.5.0,<2.0a0|>=1.7.4,<2.0a0|>=1.7.6,<2.0a0|>=2.4.0,<3.0a0']
anaconda==2020.07 -> harfbuzz==2.4.0=hca77d97_1
anaconda==2020.07 -> pango==1.45.3=hd140c19_0 -> harfbuzz[version='>=2.4.0,<3.0a0']

Package pyrsistent conflicts for:
anaconda==2020.07 -> jsonschema==3.2.0=py36_0 -> pyrsistent[version='>=0.14.0']
anaconda==2020.07 -> pyrsistent==0.16.0[build='py38h7b6447c_0|py37h7b6447c_0|py36h7b6447c_0']
jsonschema -> pyrsistent[version='>=0.14.0']
jupyterlab_server -> jsonschema[version='>=3.0.1'] -> pyrsistent[version='>=0.14.0']
nbformat -> jsonschema[version='>=2.4,!=2.5.0'] -> pyrsistent[version='>=0.14.0']

Package fontconfig conflicts for:
pyqt -> qt=5.9 -> fontconfig[version='>=2.12.4,<3.0a0|>=2.12.6,<3.0a0|>=2.13.0,<3.0a0']
anaconda==2020.07 -> cairo==1.14.12=h8948797_3 -> fontconfig[version='>=2.13.0,<3.0a0']
qt -> fontconfig[version='>=2.12.4,<3.0a0|>=2.12.6,<3.0a0|>=2.13.0,<3.0a0']
cairo -> fontconfig[version='>=2.12.4,<3.0a0|>=2.12.6,<3.0a0|>=2.13.0,<3.0a0']
harfbuzz -> cairo[version='>=1.14.12,<2.0a0'] -> fontconfig[version='>=2.12.4,<3.0a0|>=2.12.6,<3.0a0|>=2.13.0,<3.0a0']
anaconda==2020.07 -> fontconfig==2.13.0=h9420a91_0
pango -> fontconfig[version='>=2.12.4,<3.0a0|>=2.12.6,<3.0a0|>=2.13.0,<3.0a0']

Package distributed conflicts for:
dask -> distributed[version='>=1.16.0|>=1.19.0|>=1.20.0|>=1.21.0|>=1.22.0|>=1.23.0|>=1.23.1|>=1.23.2|>=1.23.3|>=1.24.2|>=1.25.0|>=1.25.3|>=1.26.0|>=1.26.1|>=1.27.0|>=1.28.0|>=2|>=2.10.0|>=2.11.0|>=2.12.0|>=2.13.0|>=2.14.0|>=2.15.0|>=2.16.0|>=2.17.0|>=2.18.0|>=2.19.0|>=2.20.0|>=2.22.0|>=2.23.0|>=2.24.0|>=2.25.0|>=2.26.0|>=2.27.0|>=2.29.0|>=2.30.0|>=2.9.2|>=2.9.1|>=2.9.0|>=2.8.1|>=2.8.0|>=2.7.0|>=2.6.0|>=2.5.2|>=2.5.0|>=2.4.0|>=2.3.0|>=2.2.0|>=1.21.1']
anaconda==2020.07 -> distributed==2.20.0[build='py38_0|py37_0|py36_0']
anaconda==2020.07 -> dask==2.20.0=py_0 -> distributed[version='>=2.20.0']
scikit-image -> dask[version='>=0.5'] -> distributed[version='>=1.16.0|>=1.19.0|>=1.20.0|>=1.21.0|>=1.22.0|>=1.23.0|>=1.23.1|>=1.23.2|>=1.23.3|>=1.24.2|>=1.25.0|>=1.25.3|>=1.26.0|>=1.26.1|>=1.27.0|>=1.28.0|>=2|>=2.10.0|>=2.11.0|>=2.12.0|>=2.13.0|>=2.14.0|>=2.15.0|>=2.16.0|>=2.17.0|>=2.18.0|>=2.19.0|>=2.20.0|>=2.22.0|>=2.23.0|>=2.24.0|>=2.25.0|>=2.26.0|>=2.27.0|>=2.29.0|>=2.30.0|>=2.9.2|>=2.9.1|>=2.9.0|>=2.8.1|>=2.8.0|>=2.7.0|>=2.6.0|>=2.5.2|>=2.5.0|>=2.4.0|>=2.3.0|>=2.2.0|>=1.21.1']

Package pyxdg conflicts for:
anaconda==2020.07 -> spyder==4.1.4=py36_0 -> pyxdg[version='>=0.26']
anaconda==2020.07 -> pyxdg==0.26=py_0
spyder -> pyxdg[version='>=0.26']

Package tbb conflicts for:
numpy-base -> tbb4py -> tbb[version='>=2018.0.4|>=2018.0.5|>=2019.0|>=2019.1|>=2019.4|>=2019.8|>=2020.0|>=2020.1|>=2020.2|>=2020.3']
numba -> tbb[version='>=2019.0|>=2019.1|>=2019.4|>=2019.8|>=2020.0|>=2020.2']
anaconda==2020.07 -> numba==0.50.1=py36h0573a6f_1 -> tbb[version='>=2020.0']
anaconda==2020.07 -> tbb==2020.0=hfd86e86_0

Package werkzeug conflicts for:
anaconda==2020.07 -> flask==1.1.2=py_0 -> werkzeug[version='>=0.15']
anaconda==2020.07 -> werkzeug==1.0.1=py_0
flask -> werkzeug[version='>=0.14|>=0.15|>=0.7,<1.0.0']

Package threadpoolctl conflicts for:
nltk -> scikit-learn -> threadpoolctl
scikit-learn -> threadpoolctl
anaconda==2020.07 -> threadpoolctl==2.1.0=pyh5ca1d4c_0
anaconda==2020.07 -> scikit-learn==0.23.1=py36h423224d_0 -> threadpoolctl

Package argh conflicts for:
anaconda==2020.07 -> argh==0.26.2[build='py38_0|py37_0|py36_0']
spyder -> watchdog -> argh[version='>=0.24.1']
anaconda==2020.07 -> watchdog==0.10.3=py36_0 -> argh[version='>=0.24.1']
watchdog -> argh[version='>=0.24.1']

Package alabaster conflicts for:
numpydoc -> sphinx -> alabaster[version='>=0.7,<0.8']
anaconda==2020.07 -> sphinx==3.1.2=py_0 -> alabaster[version='>=0.7,<0.8']
anaconda==2020.07 -> alabaster==0.7.12[build='py_0|py37_0|py36_0']
spyder -> sphinx[version='>=0.6.6'] -> alabaster[version='>=0.7,<0.8']
sphinx -> alabaster[version='>=0.7,<0.8']

Package imageio conflicts for:
scikit-image -> imageio[version='>=2.1.0|>=2.3.0']
anaconda==2020.07 -> scikit-image==0.16.2=py36h0573a6f_0 -> imageio[version='>=2.3.0']
anaconda==2020.07 -> imageio==2.9.0=py_0

Package jaraco.itertools conflicts for:
zipp -> jaraco.itertools
importlib-metadata -> zipp[version='>=0.5'] -> jaraco.itertools
importlib_metadata -> zipp[version='>=0.5'] -> jaraco.itertools

Package twisted conflicts for:
prometheus_client -> twisted
notebook -> prometheus_client -> twisted

Package mpfr conflicts for:
gmpy2 -> mpfr[version='3.*|>=4.0.1,<5.0a0']
mpc -> mpfr[version='3.*|>=4.0.1,<5.0a0']
gmpy2 -> mpc -> mpfr
anaconda==2020.07 -> gmpy2==2.0.8=py36h10f8cd9_2 -> mpfr[version='>=4.0.1,<5.0a0']
anaconda==2020.07 -> mpfr==4.0.2=hb69a4c5_1
sympy -> gmpy2[version='>=2.0.8'] -> mpfr[version='3.*|>=4.0.1,<5.0a0']

Package graphite2 conflicts for:
anaconda==2020.07 -> harfbuzz==2.4.0=hca77d97_1 -> graphite2[version='>=1.3.14,<2.0a0']
harfbuzz -> graphite2[version='1.3.*|>=1.3.10,<2.0a0|>=1.3.11,<2.0a0|>=1.3.13,<2.0a0|>=1.3.14,<2.0a0']
anaconda==2020.07 -> graphite2==1.3.14=h23475e2_0
pango -> harfbuzz[version='>=1.7.6,<2.0a0'] -> graphite2[version='1.3.*|>=1.3.10,<2.0a0']
pango -> graphite2[version='>=1.3.11,<2.0a0|>=1.3.12,<2.0a0|>=1.3.13,<2.0a0|>=1.3.14,<2.0a0']

Package fribidi conflicts for:
anaconda==2020.07 -> fribidi==1.0.9=h7b6447c_0
anaconda==2020.07 -> pango==1.45.3=hd140c19_0 -> fribidi[version='>=1.0.9,<2.0a0']
pango -> fribidi[version='>=1.0.2,<2.0a0|>=1.0.4,<2.0a0|>=1.0.5,<2.0a0|>=1.0.9,<2.0a0']

Package heapdict conflicts for:
zict -> heapdict
anaconda==2020.07 -> heapdict==1.0.1=py_0
distributed -> zict[version='>=0.1.3'] -> heapdict
anaconda==2020.07 -> zict==2.0.0=py_0 -> heapdict

Package pydocstyle conflicts for:
anaconda==2020.07 -> pydocstyle==5.0.2=py_0
anaconda==2020.07 -> python-language-server==0.34.1=py36_0 -> pydocstyle[version='>=2.0.0']
python-language-server -> pydocstyle[version='>=2.0.0']
spyder -> python-language-server[version='>=0.34.0,<1.0.0'] -> pydocstyle[version='>=2.0.0']

Package python-language-server conflicts for:
anaconda==2020.07 -> spyder==4.1.4=py36_0 -> python-language-server[version='>=0.34.0,<1.0.0']
spyder -> python-language-server[version='>=0.31.2,<0.32.0|>=0.31.9,<0.32.0|>=0.34.0,<1.0.0']
anaconda==2020.07 -> python-language-server==0.34.1[build='py38_0|py37_0|py36_0']

Package filelock conflicts for:
conda-build -> filelock
anaconda==2020.07 -> filelock==3.0.12=py_0

Package jupyterlab_server conflicts for:
jupyterlab -> jupyterlab_server[version='>=0.2.0,<0.3.0|>=1.0.0,<2.0.0|>=1.1.0,<2.0.0']
_ipyw_jlab_nb_ext_conf -> jupyterlab -> jupyterlab_server[version='>=0.2.0,<0.3.0|>=1.0.0,<2.0.0|>=1.1.0,<2.0.0']
anaconda==2020.07 -> jupyterlab_server==1.2.0=py_0
anaconda==2020.07 -> jupyterlab==2.1.5=py_0 -> jupyterlab_server[version='>=1.1.0,<2.0.0']

Package blosc conflicts for:
anaconda==2020.07 -> pytables==3.6.1=py36h71ec239_0 -> blosc[version='>=1.16.3,<2.0a0']
anaconda==2020.07 -> blosc==1.19.0=hd408876_0
pytables -> blosc[version='>=1.14.3,<2.0a0|>=1.14.4,<2.0a0|>=1.15.0,<2.0a0|>=1.16.3,<2.0a0']

Package ripgrep conflicts for:
conda-build -> ripgrep
anaconda==2020.07 -> ripgrep==11.0.2=he32d670_0

Package zope.interface conflicts for:
pytest -> attrs[version='>=17.2.0'] -> zope.interface
anaconda==2020.07 -> zope.interface==4.7.1[build='py38h7b6447c_0|py37h7b6447c_0|py36h7b6447c_0']
anaconda==2020.07 -> gevent==20.6.2=py36h7b6447c_0 -> zope.interface
gevent -> zope.interface
prometheus_client -> twisted -> zope.interface[version='>=4.0.2|>=4.4.2']
attrs -> zope.interface

Package anaconda-project conflicts for:
anaconda==2020.07 -> anaconda-project==0.8.4=py_0
anaconda-navigator -> anaconda-project[version='>=0.4']

Package numexpr conflicts for:
pytables -> numexpr
anaconda==2020.07 -> pytables==3.6.1=py36h71ec239_0 -> numexpr
anaconda==2020.07 -> numexpr==2.7.1[build='py37h423224d_0|py36h423224d_0|py38h423224d_0']

Package libllvm10 conflicts for:
numba -> llvmlite[version='>=0.34.0,<0.35'] -> libllvm10[version='>=10.0.1,<10.1.0a0']
llvmlite -> libllvm10[version='>=10.0.1,<10.1.0a0']

Package rope conflicts for:
anaconda==2020.07 -> python-language-server==0.34.1=py36_0 -> rope[version='>=0.10.5']
python-language-server -> rope[version='>=0.10.5']
spyder -> rope[version='>=0.10.5|>=0.9.4']
anaconda==2020.07 -> rope==0.17.0=py_0

Package glob2 conflicts for:
conda-build -> glob2[version='>=0.6']
anaconda==2020.07 -> glob2==0.7=py_0

Package pathtools conflicts for:
watchdog -> pathtools[version='>=0.1.1']
spyder -> watchdog -> pathtools[version='>=0.1.1']
anaconda==2020.07 -> watchdog==0.10.3=py36_0 -> pathtools[version='>=0.1.1']
anaconda==2020.07 -> pathtools==0.1.2=py_1

Package jupyterlab conflicts for:
anaconda==2020.07 -> jupyterlab==2.1.5=py_0
_ipyw_jlab_nb_ext_conf -> jupyterlab

Package curl conflicts for:
anaconda==2020.07 -> curl==7.71.1=hbc83047_1
pycurl -> curl[version='7.55.*|>=7.55.1,<8.0a0']



Fernando Luco

unread,
Nov 16, 2020, 7:25:06 PM11/16/20
to Anaconda - Public, Fernando Luco
Installing in a new environment did the trick. No problems now.
Reply all
Reply to author
Forward
0 new messages